Decks out of sync between Anki & Ankidroid

OK I know Ankidroid support is different, but I thought I would post it here as well, since I don’t know where the problem is.

I run Anki on a Windows 10 PC and on an Android mobile phone. Up till recently all was ok, and I could study on both devices and when I synced from either the counts matched on both systems.

I believe this problem started on the day in October when the clocks changed back from Summer Time. Now, although I get no error messages, my counts on the two devices do not match and I find myself doing cards on my phone one day which I’m sure I did correctly on my PC the day before.

I’ve forced an upload from PC to the web and a download from the web to the phone, but the counts are still wrong. I’ve tried deleting the phone app and reinstalling, but that makes no difference.

As far as I can tell both systems are on the same time and time zone.

Any ideas?

1 Like

The problem has disappeared as from yesterday. I do not know why, but the clocks changed again this Sunday, so it must be something to do with that.

I suspect that, although my phone and my PC show the same time, somehow Anki or Ankidroid think there is a difference, but that this problem only occurs with normal time and not with summer time.

In ankidroid under settings>reviewing, what do you have as the start of next day?

Also on your PC in preferences (I think) there’s something that says next day time or something similar, what do you have that set at?

For me, I have them both set to 8 hours and for half the year it’s off by just 1 hour on ankidroid because it doesn’t support timezone handling yet.

The next release of ankidroid which might be coming in a month or so is going to include timezone handling while new versions of anki for PC also contain an option for timezone handling which you should currently have unchecked, but can checkmark it once ankidroid support is there.

Thanks for that. Both my PC & Android are currently set to 0 hours after midnight.

Once the new timezone handling comes out I’ll check that option, but, given there is no problem during the summer, I’ll find out in October if the problem is solved.

That’s the problem right there. One app thinks that 12am is today and the other app thinks it’s yesterday because of the 1 hour issue. Set it to something like 2 or 3 hours past midnight at minimum. Then it can’t get messed up with a 1 hour difference. 0 or 1 hours past can cause a problem.