Anki Forums

Ctrl+shift shortcuts don't work

As the title says, all the shortcuts that require Ctrl and shift (like Cloze Deletion [Ctrl-Shift-c] and HTML Editor [Ctrl-Shift-x]) don’t trigger. This is without addons.

Anki is 2.1.46.

I cannot recreate it. The cloze deletion shortcut will only work on cloze note types.

In any case, you should update to 2.1.47 (it’s a bug-fix release).

1 Like

I tried this on a Linux system, and I can not reproduce the problem there either.

I have updated to 2.1.47, and I have realized I completely missed the real bug.

When I first saw I was unable to use shift in shortcuts, I manually disabled all the addons, then I restarted Anki, and it still didn’t work. So I reported it.

A few days later, I have updated Anki to 2.1.47, then held [Shift] while starting it to check if the bug was still there, and, surprise! Anki synced and the addons were enabled, even though I help [Shift] (and of course I still couldn’t use the shortcuts). I have tried several times, holding shift before launching Anki, after launching Anki, at the precise moment I launch Anki.

Since I have two computers whose configuration should be almost identical (the only difference being the X server) - which means all the programs installed have the exact same version and configuration -, I tried on the other one as well. There, no problems, I can’t reproduce the bug. So I launched xev, and indeed when I press [Shift], the same event triggers on both.

I am really curious to know what the problem is, if you have any idea.

For the sake of completeness:

  • Anki: 2.1.47 (dc156f34)
  • Python: 3.8.1
  • Qt & PyQt: 5.15.1
  • OS: NixOS 21.05 / Linux 5.10.64 [Anki comes from the unstable channel, not the 21.05 one]

I confirm I still have this issue on Anki 2.1.48.