Can't open the window to Add Cards, the window "Select color" open automatically

Hi, I have the same error of the follow topic: "choose color" dialog box bug

The window to select color appear when I try to open the Add windows. This happens when I click on the button Add or when I press ‘a’ instead of clicking. I don’t use any software in my machine that may alter keystrokes.

Sometimes the follor error appear:

Ocorreu um erro. Por favor, vá para Ferramentas > Verificar Banco de Dados para ver se isso corrige o problema.
Se o problema persistir, por favor relate-o em nossa página de ajuda. Copie e cole a informação abaixo dentro de seu relatório.
Anki 2.1.15 (442df9d6) Python 3.6.1 Qt 5.9.7 PyQt 5.9
Platform: Windows 10
Flags: frz=True ao=False sv=2
Caught exception:
File “aqt\”, line 216, in checkFocus
File “aqt\”, line 526, in onChangeCol
<class ‘RuntimeError’>: wrapped C/C++ object of type AddCards has been deleted

I’ve tried:

checking database,
deleting the add-ons
refreshing and restarting
run antivirus scan
run Anki as admin

I’ve tried too different versions of Anki, since 2.1.15 until 2.1.65, all versions this problem happend. I’ve tried alternate versions too, but didn’t work either. This is my debbug info:

Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.4.3 PyQt 6.4.0
Platform: Windows-10-10.0.19041
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2023-08-16 11:09:35
===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
===IDs of active AnkiWeb add-ons===
===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

The color selector is triggered via F8. Maybe that key is stuck down, or being triggered by some third-party tool?

The F8 key isn’t stuck down and I don’t think that any tool is triggering the window select color (this began to happen recently, without the installation of any program). The select color window just freeze, it’s impossible to close it without closing anki completely

Out of curiosity, but maybe try using Keyboard Manager from Microsoft PowerToys to remap some keys.

  • Maybe try disabling F8 , then press ‘a’ in Anki and see what happens.

  • Maybe map the ‘pause’ key to the ‘a’ key and see what happens when you press the ‘pause’ key in Anki. It should just open the Add window.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.