Can't load Anki onto MacBook

Something has happened when I installed a new version of Anki onto my Mac. Now nothing happens when I open Anki (it shows that it’s not responding). I’ve tried a few different versions to see if this changes matters - it doesn’t.

My plan now is to delete Anki completely and reinstall it. I don’t want my data deleted though! How do I go about this?
I’m thinking one way would be to go to the folder in the “library” where the data is installed called “Anki 2” and rename this folder so that the data is not deleted when Anki is deleted. Then when I install the new version of Anki rename the folder back to “Anki 2” - will this work?


This may work, but you might want to try some other fixes first. Regardless, you’re right to back up your Anki data first before monkeying with anything.

Have you tried launching Anki with add-ons disabled? Back when I was on Mac this usually let me troubleshoot any issues with Anki not loading.

If you do decide to replace the Anki 2 directory, you’ll probably also want to replace the plist file.

Be sure to back up both the plist file and the Anki2 directory so that you can restore if needed.

If you rename the Anki2 folder while Anki is closed, Anki will create a new one when you next start it. If it starts correctly, that indicates the issue was with an add-on or something in your prefs21.db file. Make sure you keep the old folder, as it also contains all your card data.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.