Can't import this Anki .akpg (note has 4 fields, expected 3)

Hey, I’m trying to import an old anki deck attached here that used to work in old versions of Anki - however, uploading the .akpg now yields the error in Anki:

I have uploaded the deck below and really have no other information on what types of notes it uses etc. I wish there was a way I could open and inspect the .akpg files but I couldn’t figure it out.

Since I couldn’t upload the .akpg deck here, I uploaded it to the following Google Drive link. I would appreciate any help with this!


I successfully imported the file into Anki 2.1.54 by attempting the import process twice. The first attempt resulted in the same error you encountered, but the second went smoothly.

I added a fourth field to the note type, and now it seems the file can be imported with more recent Anki versions as well:


Works great now - love you for this man! So just so I understand - did you use an older Anki version to get it to work or did you just do the twice uploading thing? I tried before with my original file importing 8 times in a row with no luck. However - your’s worked on the second try like you said!

1 Like

I performed the following steps:

  1. Attempted to import your file with Anki 23.12 beta3 without success.
  2. Switched to Anki 2.1.54 and successfully imported the file on the second attempt.
  3. Added a fourth field and exported the deck into a new file.
  4. Tried importing the new file with Anki 23.12 beta3, and the import process went smoothly on the first attempt.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.