Can't download Anki on terminal linux

Hello Anki, I have been a user of this software for a very long time however, lately, I have been facing many issues.
On Thursday, I opened Anki to use it for my GCSE mock revision however as I opened it anki said “An add-on you installed failed to load” so I decided to delete and re-download the addon. This add-on was a review heatmap.
However every solution I tried didn’t work, so I contacted the developer of this add-on with screenshots via email, I was told that I have the older version of Anki and the older version of the add-on so he directed me to the Anki website where it told me how to install and upgrade Anki on Linux. Bear in mind I have a Galaxy Chromebook OS 2 which contains a terminal I have no clue how to use. So I tried using the guide from Anki it didn’t help so I went to YouTube and Reddit to seek other solutions however nothing worked until I stumbled upon a YouTube video which guided me through how to uninstall apps on Linux, I used this guide to uninstall Anki with my intentions been that after I have uninstalled anki I will download it again with the new version, however, this was not the case as I have spent 3 days trying to install anki back on the terminal again that I even seek help from AI apps giving commands. Every command I try they never work.
Please Anki help me get this app back on my Chromebook as I am desperately trying to revise it for my upcoming GCSE mocks

Please, copy paste an example of the command lines your typing in terminal and the results even if it’s unclear to you. It should be something like this:

$ sudo apt install libxcb-xinerama0 libxcb-cursor0 libnss3
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ tar xaf Downloads/anki-2XXX-linux-qt6.tar.zst
tar: Downloads/anki-2XXX-linux-qt6.tar.zst: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

Should I just put in 2XXX or should I replace it with a version.
If so can you recommend me the version to replace 2XXX

Open a terminal and run the following commands, replacing the filename as appropriate.

tar xaf Downloads/anki-23.12.1-linux-qt6.tar.zst
cd anki-23.12.1-linux-qt6
sudo ./

Latest version Qt 6

1 Like

I have used the commands you suggested, however Linux came up with this

I have used the command lines you told me to use

Try the following based on this thread

cd Downloads
tar xaf Downloads/anki-23.12.1-linux-qt6.tar.zst
cd anki-23.12.1-linux-qt6
sudo ./

if it doesn’t work, then

cd /mnt/chromeos/MyFiles/Downloads
tar xaf /mnt/chromeos/MyFiles/Downloads/anki-23.12.1-linux-qt6.tar.zst
cd anki-23.12.1-linux-qt6
sudo ./

Another easy way to set up anki would be using flatpak
Chrome OS Flathub Setup | Flathub
then Install Anki on Linux | Flathub

Support is Unofficial

You are welcome to continue using your distro’s version of Anki if you prefer, but if you run into any issues, you will need to report them to your distribution’s package maintainers.
Linux Distro Packages - Anki Manual

Let us know which method it worked

Could you do uname -m to see if your system is ARM/Aarch64 or 64bits Intel/AMD

Flatpak will install the latest version if it is 64 bits, but will install the older version for ARM/Aarch64

latest versions of ARM/Aarch64 can be installed via python wheels (idk how to setup)

1 Like

Hi have tried the first command line

I have tried the second command line

Can you guide me through in how to get flathub please

I have put in uname

  • m

However on my setting on the about chromeos it says this

The setup is pretty straight forward

then once it is done, just

flatpak install flathub net.ankiweb.Anki
1 Like

I am very sorry to continuously bother,
I have used the guide you linked to get flathub

Remember step 5. Restart

To complete setup, restart Linux. You can do this by right-clicking terminal, and then clicking “Shut down Linux”. Now all you have to do is install some apps!

1 Like

I have completed step 5.However I can’t find flat pack anywhere, although i have got this

Sorry, thought the icon would appear once Anki was installed, then use this

flatpak run net.ankiweb.Anki

After you start anki, right click the icon and try to pin the app in your desktop/docker/toolbar


I have successfully done it, however it says

I have got the Anki icon appeared on the system

However, when I open it, it just comes up with this

Linux on Chromebook runs via a container and uses Wayland. Any gui program which is not able to use Wayland will not run.
Reddit - Dive into anything

Anki support on Wayland works, but it is not perfect, you can track and report issues here:


sorry to keep bothering you, however, I am confused about what you want me to do next please.

It runs fine right? you can access anki installation prompt

just ignore the terminal warning

Is the prompt not installing?

Reported in Installation crashing in x86_64 for Chromebooks · Issue #135 · flathub/net.ankiweb.Anki · GitHub

For now, try using AnkiDroid in the play store until the issue is fixed