Cannot open up the options menu in Anki app

I tried to open up the settings menu of my deck in anki by clicking on the gear icon, but it wouldn’t allow me to. After checking the database in the tools menu, it still doesn’t work. Here is the error message:

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.15 (442df9d6) Python 3.11.2 Qt 5.15.8 PyQt 5.15.9
Platform: Linux
Flags: frz=False ao=False sv=2

Caught exception:
File “/usr/share/anki/aqt/”, line 213, in
a.triggered.connect(lambda b, did=did: self._options(did))
File “/usr/share/anki/aqt/”, line 242, in _options
File “/usr/share/anki/aqt/”, line 869, in onDeckConf
aqt.deckconf.DeckConf(self, deck)
File “/usr/share/anki/aqt/”, line 25, in init
File “/usr/share/anki/aqt/”, line 49, in setupConfs
File “/usr/share/anki/aqt/”, line 66, in loadConfs
File “/usr/share/anki/aqt/”, line 89, in onConfChange
File “/usr/share/anki/aqt/”, line 175, in loadConf
<class ‘TypeError’>: setValue(self, val: int): argument 1 has unexpected type ‘float’

This is a very old version from the repo, try installing a newer version from the web

1 Like

Please update this very old Anki version using a download from the Anki website. It is a known issue with this outdated version (likely distributed through package managers), that does not occur in recent versions.

1 Like

I tried downloading the newer version of Anki, but I got the error:
-bash: /usr/local/bin/anki: cannot execute binary file: Exec format error

I have a ARM CPU. This means that I can’t update to a newer version. Is the version that I have the newest I can get with ARM? I followed the 2021 reddit guide on how to install anki with ARM and it said that I could only do the first step. I did the first step and I got this:

~$ sudo apt-get update && sudo apt-get install anki

The important thing to highlight is that it says “anki is already the newest version (2.1.15)

So TLDR I think my anki is already the newest version I can get with a ARM cpu.

1 Like

I keep trying to download it and when I replace the file name with my file’s name, it says the file is not found even though I entered my file’s name correctly. I have tried this multiple times. Below is what I entered into linux as per the instructions and the pictures of the file name in my linux file folder:
Screenshot 2023-12-27 3.55.43 PM
Screenshot 2023-12-27 3.55.37 PM

It looks like you have to decompress the file first

Do you know how I could do that? The anki guide didn’t say anything on how to do that and when I looked it up online it only gave me results on how to zip and unzip files. Thank you so much for your help

From the link above:

If you are on a different architecture, or a barebones Linux distro, you will not be able to use the packaged version, but you may be able to use the Python wheels instead.

I ran the first command on that page of sudo apt install python3-pyqt5.{qtwebengine,qtmultimedia} successfully, but the next one wasn’t working no matter what I tried. I input the code, and it then said to run something else, which I did, but it still wasn’t working. I have attached a picture of it below. The second line of code I ran in the picture was the one instructed to be run in the anki instructions. I appreciate your assistance.

The top command installed it for python 3.11, so try replacing 3.9 with 3.11 in the second command.

Ok, so I tried what you said twice and it just said “Error: Command ‘[’/home/pyenv/bin/python3.11’, ‘-m’, ‘ensurepip’, ‘–upgrade’, ‘–default-pip’]’ returned non-zero exit status 1.” See attached picture.

Try removing pyenv then repeating the command.

Ok, I tried removing pyenv from the commands and here’s what I got:

On a side note, I checked and I am operating on Debian 12.

Sorry, I was not clear. I meant removing the out/pyenv directory that was created, not changing the command.

Ok, I tried removing the pyenv file from my computer found in files that was titled “pyenv” and then I tried again. The only problem is when I try running the command it just gives me nothing. My linux is being unresponsive. Any pointers on how to fix?

After running the command once, you can try following the subsequent instructions in the docs again.

Ok, I tried following the commands coming afterward in the website like you said. The instructions said to run some commands next, which I did. But it still didn’t get installed. I have attached the screenshot of my attempts.
Screenshot 2024-01-14 11.11.36 PM

pip should be in pyenv/bin after the venv command. Maybe you need to install python3-pip and then start again.

Ok, I tried installing python and pip but it said that I already had the newest version installed. I then tried running the command on the doc again but the same thing happened.
Screenshot 2024-01-16 8.14.16 AM