BuryNdays [Official Thread]

anki-BuryNdays

Burying siblings (system built-in function) for one day is not enough? Then bury them for N days.

How does it work?

When you enter a deck, it will bury cards automatically.

You can configure it in deck options.

1 Like

Sounds good. Could you provide a link to it? thanks

https://ankiweb.net/shared/info/1703028231

That looks useful! However, when I enter the deck preview screen, I get this error:

Debug info:
Anki 2.1.61 (0c1eaf4c) Python 3.9.15 Qt 6.4.2 PyQt 6.4.0
Platform: Windows-10-10.0.19045
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2023-04-10 10:27:03

Caught exception:
Traceback (most recent call last):
  File "aqt.taskman", line 122, in _on_closures_pending
  File "aqt.taskman", line 71, in <lambda>
  File "aqt.taskman", line 90, in wrapped_done
  File "aqt.operations", line 125, in wrapped_done
  File "aqt.deckbrowser", line 129, in <lambda>
  File "aqt.main", line 1212, in onOverview
  File "aqt.main", line 711, in moveToState
  File "aqt.main", line 729, in _overviewState
  File "aqt.overview", line 61, in show
  File "aqt.overview", line 69, in refresh
  File "_aqt.hooks", line 3577, in __call__
  File "C:\Users\jcznk\AppData\Roaming\Anki2\addons21\1703028231\BuryNdays.py", line 49, in autobury
    for cid in mw.col.db.list(dbstr):
  File "anki.dbproxy", line 72, in list
  File "anki.dbproxy", line 61, in _query
  File "anki._backend", line 92, in db_query
  File "anki._backend", line 116, in _db_command
anki.errors.DBError: DbError { info: "SqlInputError { error: Error { code: Unknown, extended_code: 1 }, msg: \"unrecognized token: \\\"{\\\"\", sql: \"SELECT id FROM cards WHERE id != 1681081085886 AND\\n                (nid = 1681081085849 OR nid IN (SELECT id FROM notes WHERE sfld = \\\"Giappone, periodo {{c1::Heisei}} ({{c2::1989}}-{{c3::2019}})<br><br>Il nome significa \\\"{{c4::pace ovunque}}\\\" e rifletteva l'auspicio che il nuovo imperatore portasse un'era di pace e stabilità dopo il turbolento periodo Showa, che vide la partecipazione del Giappone alla Seconda Guerra Mondiale e la sua sconfitta. Durante tale periodo, il Giappone ha affrontato diversi problemi interni ed esterni, come la crisi economica, il disastro di Fukushima e il rinnovamento delle tensioni con la Corea del Nord.<br>L'imperatore {{c5::Akihito}} annunciò la sua abdicazione nel {{c3::2019}} in favore del figlio {{c6::Naruhito}}, e il periodo successivo, dal {{c7::1º maggio 2019}}, è chiamato \\\"{{c8::Reiwa}}\\\", scelto sempre dal governo giapponese.\\\"))\", offset: 221 }", kind: Other }

I guess some symbols (like {{c1::Heisei}}) in your note provoke this error, because my notes don’t contain them. I will test and try to fix it.

It’s already fixed. Turns out it was because I didn’t handle quotation marks.

Thanks for the link
but
when I attempt to install, I get the message
“1703028231: invalid code, or add-on not available for your version of Anki”
I am using Anki version 2.1.45 - is there an incompatibility?

Well, I only tested it under 2.1.61, so I’m not sure what will happen under 2.1.45. If you want to use this, maybe you have to upgrade your anki.

thanks for the clarification

Can I just check with you, does ticking the box “Bury across decks” (in deck options, not visible in your screenshot) mean that the function will apply to all sub-decks?

Exactly speaking, if you check this box, it will affect all decks rather than all sub-decks.

Thanks for the clarification.

Something else has come up which seems to be related to the add-on:

when I first open up my main deck I get the error message copied below. When I close the error window, I can proceed as usual, but I haven’t actually tested whether the add-on is working nonetheless. (Not sure how I would do this.)

thanks in anticipation for your efforts to put this right!

best regards,

guido

Error

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.

If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem.

When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.

Debug info:

Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.4.3 PyQt 6.4.0

Platform: Windows-10-10.0.19044

Flags: frz=True ao=True sv=2

Add-ons, last update check: 2023-06-09 08:12:59

Caught exception:

Traceback (most recent call last):

File “aqt.taskman”, line 122, in _on_closures_pending

File “aqt.taskman”, line 71, in

File “aqt.taskman”, line 90, in wrapped_done

File “aqt.operations”, line 125, in wrapped_done

File “aqt.deckbrowser”, line 129, in

File “aqt.main”, line 1224, in onOverview

File “aqt.main”, line 712, in moveToState

File “aqt.main”, line 730, in _overviewState

File “aqt.overview”, line 61, in show

File “aqt.overview”, line 69, in refresh

File “_aqt.hooks”, line 3650, in call

File “C:\Users\guido\AppData\Roaming\Anki2\addons21\1703028231[BuryNdays.py](http://BuryNdays.py)”, line 23, in autobury

cards = mw.col.sched.get_queued_cards(fetch_limit=10000).cards

File “anki._legacy”, line 80, in getattr

AttributeError: ‘Scheduler’ object has no attribute ‘get_queued_cards’

Or does it just affect all other decks in the same options group?

I updated the add-on to fix some errors.

No, it will affect all other decks.

Thanks for the update, which I have now installed. The previous error seems to be sorted, but I now get a new error message which also refers to BuryNdays, please see below. Thanks for your continuing efforts to get this right!

best wishes, guido

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.
Debug info:
Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.4.3 PyQt 6.4.0
Platform: Windows-10-10.0.19044
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2023-06-13 17:34:46

Caught exception:
Traceback (most recent call last):
File “aqt.taskman”, line 122, in _on_closures_pending
File “aqt.taskman”, line 71, in
File “aqt.taskman”, line 90, in wrapped_done
File “aqt.operations”, line 125, in wrapped_done
File “aqt.deckbrowser”, line 129, in
File “aqt.main”, line 1224, in onOverview
File “aqt.main”, line 712, in moveToState
File “aqt.main”, line 730, in _overviewState
File “aqt.overview”, line 61, in show
File “aqt.overview”, line 69, in refresh
File “_aqt.hooks”, line 3650, in call
File “C:\Users\guido\AppData\Roaming\Anki2\addons21\1703028231\BuryNdays.py”, line 108, in autobury
cards = mw.col.sched.get_queued_cards(fetch_limit=10000).cards
File “anki._legacy”, line 80, in getattr
AttributeError: ‘Scheduler’ object has no attribute ‘get_queued_cards’

Have just got another error message, this one extremely long, so I won’t copy it. It seems to contain a huge number of references to BuryNdays line 213, and just a couple of references to lines 206 and 215

I guess it is because you used a v2 scheduler. This function is only defined in the v3 scheduler. So if you need to use this, you have to change into the v3.

Thanks for this new clarification. I have now changed to the v3 and those error messages previously mentioned have disappeared. However sometimes when reviewing cloze cards I now get a new error message, referring to BuryNdays line 187, see below. After closing the error message I then get an alert message (also below). After closing the alert I can’t do anything more with the card, so have to return to the decks menu to continue.

I hope you are finding my ongoing feedback not just annoying but also helpful.

regards, guido

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.
Debug info:
Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.4.3 PyQt 6.4.0
Platform: Windows-10-10.0.19044
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2023-06-15 08:41:51

Caught exception:
Traceback (most recent call last):
File “aqt.taskman”, line 122, in _on_closures_pending
File “aqt.taskman”, line 71, in
File “aqt.taskman”, line 90, in wrapped_done
File “aqt.operations”, line 125, in wrapped_done
File “aqt.reviewer”, line 460, in after_answer
File “aqt.reviewer”, line 473, in _after_answering
File “_aqt.hooks”, line 3982, in call
File “C:\Users\guido\AppData\Roaming\Anki2\addons21\1703028231\BuryNdays.py”, line 187, in AnsweredQus
list = mw.col.db.list(dbstr)
File “anki.dbproxy”, line 72, in list
File “anki.dbproxy”, line 61, in _query
File “anki._backend”, line 92, in db_query
File “anki._backend”, line 116, in _db_command

Alert:
card was modified: Normal(
Review(
ReviewState {
scheduled_days: 30,
elapsed_days: 30,
ease_factor: 1.5,
lapses: 2,
leeched: false,
},
),
) Normal(
Relearning(
RelearnState {
learning: LearnState {
remaining_steps: 1,
scheduled_secs: 259200,
},
review: ReviewState {
scheduled_days: 30,
elapsed_days: 30,
ease_factor: 1.5,
lapses: 2,
leeched: false,
},
},
),
)

ps same error has also now occurred with non-cloze cards

Don’t worry about this. It’s really helpful.

The error you mentioned is fixed.