Bug report: When I continue learning Anki using only keyboard input (Enter, 1, 2, 3, 4), sometimes the answers are not displayed.(Linux)

  1. Learn only with keyboard shortcuts without using a mouse.
  2. Sometimes the screen does not update even though I press (Enter) to display the answer.
  3. Move the mouse pointer momentarily and the answer will be displayed instantly.

I suspect that there is an internal process that stops updating the screen if the mouse is not used for a certain period of time.

Unless this is something Linux-specific (in which case, I wouldn’t know :sweat_smile: ) –
To me, “screen does not update” sounds like a video driver problem. See #6 on the Troubleshooting checklist and try all the options. Troubleshooting - Anki Manual

No, this is not a beginner’s report of the screen not updating at all.
After repeating reviews for a while, the symptoms suddenly appear, so there is a high possibility that it is a bug.
I tried changing to Wayland mode and changing the video driver, but the symptoms did not change.

Are you sure you tried all video drivers, and restarted each time you made a change?

1 Like

I have tried all three settings, but the bug remains.
Is there any way to know which graphic settings are actually being applied, e.g. from the console logs?
Also, does the bug reproduce in environments other than mine?

Besides the graphics problem, it could also be a problem with the keyboard input handling. Is there a debug mode or something that shows the keyboard input received by anki?

I’m also on linux and used anki recently on both Wayland and X11 and I never had this issue. Assuming you’re on a Wayland environment, it may be that you are using the X11 version by accident, which doesn’t really work well on Wayland and I can see that being the issue. Try to install the package qt6-wayland and set the env var ANKI_WAYLAND=1 again and see if that works.

1 Like

If you’re adjusting the driver via the preferences screen, a restart should be all you need. You can see some info about the current driver by setting the env var QT_LOGGING_RULES=qt.webenginecontext.debug=true before starting Anki.

According to the logs, it appears that the graphics settings are being applied correctly. Also, no additional logs appeared when the bug occurred. I tried starting the Wayland version of Anki and the X11 version of GNOME on the advice of @raidenfox, but the problem persists.
I tried enabling/disabling Reduce Motion in the settings, but the problem remains the same.

Did you try both Qt6 and Qt5 versions?

I removed the video driver from my PC and the bug no longer occurs.
In other words, even if I start Anki with the “Software” settings, the current Anki may actually still be using OpenGL, etc.
This situation is inconvenient because I can’t keep removing video drivers all the time.

If even the software setting in Anki is failing, that sounds like an issue with the video driver I’m afraid.

Does this also affect with NVIDIA drivers? I heard some issues with GNOME with both X11 and Wayland. Using X11 and Intel drivers (open) isn’t an issue from now, but may test it with an NVIDIA card

I’m using Intel iHD driver.

Even with the driver disabled, the bug still occurred.
It seems I was wrong to think that disabling the driver temporarily resolved the bug.

Sorry, I’m not sure what the problem is, and can’t reproduce it here.

yes it is also happen on mac(M2).
when i review the card i make although it is very simply with just some words without any picture, it still happen.
I have searched for it on the internet but nothing.

I have tried the same card in windows. it’s OK.
so i think it is because the app is now having some bugs.

You are on a different OS, and likely do not have the same problem as the original poster. Please follow the step on Troubleshooting - Anki Manual

The bug occurs in GNOME and KDE, but I have confirmed that it does not occur in Hyprland.
I will continue to investigate the cause.