Browser: Table/Editor side-by-side (horizontal split) [Official thread]

If you have a problem with the add-on Browser: Table/Editor side-by-side (horizontal split) post in this thread. This way I get notified. If you make a new thread I might miss it.

Consistently breaking images in other fields when jumping between cards in editor (gives no media image found icon). Fixed only with disabling addon.

Please let me know what else you’d like to know.

For me it works and I’ve have never gotten a similar bug report even though the add-on seems to be quite widely used. So I have no idea at the moment.

To get a better understanding of the problem I need some info:

  • If you disable all other add-ons, enable “Browser: Table/Editor side-by-side”, restart Anki, does this still happen? If the problem disappears it could be an add-on conflict. To find out which add-ons conflict you could enable half of the add-ons you have, restart anki and try again. If it still works enable half of the remaining disabled half, restart and try again. If you repeat this a few cycles you should find out the bad combination. Tell me which add-ons conflict and then there’s a good chance that it can be solved. Since there are over 600 add-ons there’s no way for me to test all combinations imaginable so your help is crucial here.
  • Which Anki version are you on? Could you try (with just my add-on) with the latest version (2.1.35)? In case you still use an older version: You don’t have to install Anki - e.g. in windows you can unzip the installer and run from this folder (after using this make sure to downgrade your profile from inside 2.1.35).
  • What operating system do you use?
  • Has this always happened or did this only recently start? Do you remember if something changed shortly before the problem started occuring?
  • Does this happen for all images or only some images? If it’s the latter: Are these always the same? Do you see some kind of pattern?

Hello! I appreciate your quick reply. Good news and bad news. Good news is I no longer get the problem. Bad news is I cannot replicate the problem after disable and reenabling all addons.

  • I only noticed the issue after updating to 2.1.35 ~1 week ago. (Windows 10)

  • I have only noticed it with some images sporadically, but today I found an image/card that I could reliably reproduce the issue with every time (until disabling/reenabling half of my addons).

I’m sorry to have bothered you, it was so sporadic before I wasn’t able to figure it out myself. If it happens again I’ll be sure to have all details after trying everything myself!

Best,
Greg

@ijgnd with the latest 2.1.41beta2 (which damien said likely will not change much) I’m getting the following error with this add-on

File “aqt/webview.py”, line 37, in cmd
File “aqt/webview.py”, line 136, in _onCmd
File “aqt/webview.py”, line 581, in _onBridgeCmd
File “”, line 2, in _linkHandler
File “anki/hooks.py”, line 89, in decorator_wrapper
File “anki/hooks.py”, line 86, in repl
File “/Users/Nick/Library/Application Support/Anki2/addons21/zkingofstudytimers/init.py”, line 616, in myLinkHandler
return _old(self, url)
File “aqt/toolbar.py”, line 170, in _linkHandler
File “aqt/toolbar.py”, line 188, in _browseLinkHandler
File “aqt/main.py”, line 1069, in onBrowse
File “aqt/init.py”, line 101, in open
TypeError: init() got an unexpected keyword argument ‘card’

the current version of “table/editor side-by-side” works for me in 2.1.41 beta3 - at least if I disable other add-ons that cause problems in 2.1.41. But maybe I missed some special situation. If you still find a problem with this add-on if you run it on its own let me know.

Youre right, mine seems to be working now. I think it may have been Advanced browser which was also having the same error

@ijgnd Stopped working after update to anki 2.1.42 from 2.1.40
Please update, i am super used to this and now it hurts my eyes :sob:

this error pops up when ever i try to open the browser.
the browser does not open at all.

 Error 
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed. 
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem. 
When you've discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site. 
Debug info:
Anki 2.1.42 (8eebfe18) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-03-14 19:07:38

Caught exception:
Traceback (most recent call last):
  File "aqt\main.py", line 1067, in onBrowse
  File "aqt\__init__.py", line 101, in open
  File "C:\Users\Mahfuz\AppData\Roaming\Anki2\addons21\874215009\advancedbrowser\core.py", line 208, in __init__
    origInit(self, mw, card, search)
  File "aqt\browser.py", line 475, in __init__
  File "<decorator-gen-88>", line 2, in setupSearch
  File "anki\hooks.py", line 89, in decorator_wrapper
  File "anki\hooks.py", line 81, in repl
TypeError: mysearch() takes 1 positional argument but 3 were given

Even after Deleting advanced browser addon i get this

Error 
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed. 
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem. 
When you've discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site. 
Debug info:
Anki 2.1.42 (8eebfe18) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-03-14 19:07:38

Caught exception:
Traceback (most recent call last):
  File "aqt\main.py", line 1067, in onBrowse
  File "aqt\__init__.py", line 101, in open
  File "aqt\browser.py", line 475, in __init__
  File "<decorator-gen-88>", line 2, in setupSearch
  File "anki\hooks.py", line 89, in decorator_wrapper
  File "anki\hooks.py", line 81, in repl
TypeError: mysearch() takes 1 positional argument but 3 were given

With only this add on On and the rest off i get this.

Error 
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed. 
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem. 
When you've discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site. 
Debug info:
Anki 2.1.42 (8eebfe18) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-03-14 19:07:38

Caught exception:
Traceback (most recent call last):
  File "aqt\webview.py", line 36, in cmd
  File "aqt\webview.py", line 135, in _onCmd
  File "aqt\webview.py", line 580, in _onBridgeCmd
  File "aqt\toolbar.py", line 169, in _linkHandler
  File "aqt\toolbar.py", line 187, in _browseLinkHandler
  File "aqt\main.py", line 1067, in onBrowse
  File "aqt\__init__.py", line 101, in open
  File "aqt\browser.py", line 475, in __init__
  File "<decorator-gen-6>", line 2, in setupSearch
  File "anki\hooks.py", line 89, in decorator_wrapper
  File "anki\hooks.py", line 81, in repl
TypeError: mysearch() takes 1 positional argument but 3 were given
1 Like

@zen: thanks for this report. It really helps a lot that you included the error messages.

At the moment I can’t reproduce the problem on my computer with Anki 2.1.42. So I need more help from you:

The last line of the last message says that there is an error in mysearch. This name of a function is more or less only used in my add-on BetterSearch. the string “mysearch” does not occur in the source code of my add-on “Browser: Table/Editor side-by-side (horizontal split)”

When you disable add-ons from the add-on dialog you must restart Anki. Only after restarting you can be certain that no code from such an add-on is executed. Maybe you have BetterSearch and haven’t restarted anki after disabling it?

The old version of BetterSearch doesn’t run in .41 and should cause such an error message, see this fix for 41.

When you update Anki the add-ons are unfortunately not updated automatically. So you might have incompatible add-ons that cause strange errors.

Could you update all your add-ons (from the main window, click Tools, then “Add-ons”, in the dialog that opens there is a button “Check for Updates” in the upper right). Then restart anki and try again. Does this problem still occur?

@ijgnd Thanks thanks alot for the reply, yes you were ryt it was better search, for some reason in this version of anki juz toggling them off with restart is not enough, they still read the code. i juz deleted better search and this addon started working again. Cool. :ok_hand:

1 Like

@zen: That’s strange. At the moment I can’t get errors when using BetterSearch and horizontal add-on. But that doesn’t say much.

So could you re-install BetterSearch, restart Anki and try again.

If it still crashes your browser please describe the exact steps to reproduce this problem. And also share the debug info that you can get like this: in the main window click on the “Help” menu, then select “About”. In the dialog that opens there’s a button “Copy Debug Info” at the bottom. Click it to get the text into your clipboard. Then share it. Hopefully this allows me to repriduce the problem so that I can fix it. This might help many other people.

@ijgnd very strange indeed. installed bettersearch again. now it does not conflict with the horizontal addon…everythings working perfectly fine now. maybe something was corrupted on my part.

Hello,
Thank you so much for the great add-on. I just recently updated my Anki to version 2.1.40. The add on is working as I suppose it is supposed to, but I was wondering if there is a way to make the editor on the side the default view? I believe I did it when I first started Anki as it has not been on the bottom in years, but I can not seem to figure it back out. Is there a way to make it so that the editor automatically always shows on the side rather than on the bottom?
Thanks in advance!

there’s an add-on setting “side-by-side is default”. Set it to true and restart anki. this should help. does it?

if it still doesn’t work: rule out an add-on conflict: disable all other add-ons and restart anki and try again (see When problems occur - Frequently Asked Questions). Also say which anki version you use.

1 Like

That fixed it! Thank you!