Anki Forums

Browser: Table/Editor side-by-side (horizontal split) [Official thread]

If you have a problem with the add-on Browser: Table/Editor side-by-side (horizontal split) post in this thread. This way I get notified. If you make a new thread I might miss it.

Consistently breaking images in other fields when jumping between cards in editor (gives no media image found icon). Fixed only with disabling addon.

Please let me know what else you’d like to know.

For me it works and I’ve have never gotten a similar bug report even though the add-on seems to be quite widely used. So I have no idea at the moment.

To get a better understanding of the problem I need some info:

  • If you disable all other add-ons, enable “Browser: Table/Editor side-by-side”, restart Anki, does this still happen? If the problem disappears it could be an add-on conflict. To find out which add-ons conflict you could enable half of the add-ons you have, restart anki and try again. If it still works enable half of the remaining disabled half, restart and try again. If you repeat this a few cycles you should find out the bad combination. Tell me which add-ons conflict and then there’s a good chance that it can be solved. Since there are over 600 add-ons there’s no way for me to test all combinations imaginable so your help is crucial here.
  • Which Anki version are you on? Could you try (with just my add-on) with the latest version (2.1.35)? In case you still use an older version: You don’t have to install Anki - e.g. in windows you can unzip the installer and run from this folder (after using this make sure to downgrade your profile from inside 2.1.35).
  • What operating system do you use?
  • Has this always happened or did this only recently start? Do you remember if something changed shortly before the problem started occuring?
  • Does this happen for all images or only some images? If it’s the latter: Are these always the same? Do you see some kind of pattern?

Hello! I appreciate your quick reply. Good news and bad news. Good news is I no longer get the problem. Bad news is I cannot replicate the problem after disable and reenabling all addons.

  • I only noticed the issue after updating to 2.1.35 ~1 week ago. (Windows 10)

  • I have only noticed it with some images sporadically, but today I found an image/card that I could reliably reproduce the issue with every time (until disabling/reenabling half of my addons).

I’m sorry to have bothered you, it was so sporadic before I wasn’t able to figure it out myself. If it happens again I’ll be sure to have all details after trying everything myself!

Best,
Greg

@ijgnd with the latest 2.1.41beta2 (which damien said likely will not change much) I’m getting the following error with this add-on

File “aqt/webview.py”, line 37, in cmd
File “aqt/webview.py”, line 136, in _onCmd
File “aqt/webview.py”, line 581, in _onBridgeCmd
File “”, line 2, in _linkHandler
File “anki/hooks.py”, line 89, in decorator_wrapper
File “anki/hooks.py”, line 86, in repl
File “/Users/Nick/Library/Application Support/Anki2/addons21/zkingofstudytimers/init.py”, line 616, in myLinkHandler
return _old(self, url)
File “aqt/toolbar.py”, line 170, in _linkHandler
File “aqt/toolbar.py”, line 188, in _browseLinkHandler
File “aqt/main.py”, line 1069, in onBrowse
File “aqt/init.py”, line 101, in open
TypeError: init() got an unexpected keyword argument ‘card’

the current version of “table/editor side-by-side” works for me in 2.1.41 beta3 - at least if I disable other add-ons that cause problems in 2.1.41. But maybe I missed some special situation. If you still find a problem with this add-on if you run it on its own let me know.

Youre right, mine seems to be working now. I think it may have been Advanced browser which was also having the same error