AwesomeTTS make Anki 2.1.41(or42) remain in background processes

To reproduce the problem:
0. Disable other Add-ons, disable win 10 defender anti-virus

  1. Create a card and open AwesomeTTS, record a mp3 file
  2. Close Anki by Click up-right corner cross.
    Anki will remain in background processes.
  3. Reopen Anki, it will show up but have no response, and setting icon(gear) don’t display properly

Win 10
Anki 2.1.42(or 2.1.41)
AwesomeTTS 1.34.0



Hi, My OS is Win 10.

In Anki 2.1.41, after I close it by click up right corner cross, the Anki process will remain in background processes.

If I don’t terminate the background Anki process manually and reopen it, the Anki process will show up, but all of the buttons are not responsive.


So, I have to manually terminate it in Task Manager each time I close it. Is it a bug? Thanks!

Do you use add-ons? Does it still happen if you disable your antivirus program?

Hi dae, the problem is caused by AwesomeTTS(there are 2 version of them, both cause the problem). And I have turned off all other add-ons. My antivirus program is Win 10 defender(default setting), I leave it enabled.

To reproduce the problem,

  1. create a card and use AwesomeTTS to generate mp3 file
  2. close Anki, and it remained in background process
  3. reopen it, Anki will show up but no response, and setting icon(gear) don’t display properly


Hi dae, I have tried to turn win 10 defender anti-virus(real time problem) off, and the problem still exist. What shall I do next?

@lucw heads up

Hi dae, After I invoke AwesomeTTS and close Anki, mpv still remain in background processes. Is it a bug?

If you close the mpv processes and start Anki while add-ons are disabled, can you reproduce the problem of the processes not going away?

Hi dae, close mpv and disable add-ons, problem not going away

To reproduce it:
0. Open Anki, Enable AwesomeTTS

  1. Click “add”, Click AwesomeTTS Icon, Don’t have to create mp3, close AwesomeTTS
  2. Disable all add-ons, Close Anki
  3. Find mpv in Task Manager and terminate it
  4. Reopen Anki, problem still exist

What’s next? Thanks!

I see you opened an issue on github, let me try to reproduce this as a first step.

1 Like

Thanks! :smiley:

@zhushenli I’m having trouble reproducing this bug, does this happen regardless of which service you use ?

@lucw Yes, this happen regardless of which service I use. Actually, I just open AwesomeTTS and close it, don’t have to create audio file.

Before I open AwesomeTTS, Anki’s CPU usage is about 1%. After I open AwesomeTTS, Anki’s CPU usage increase to 16%. I have a 6 logical core CPU, so I guess AwesomeTTS run into some kind of infinite loop and eat up one logical core. Then I close Anki, and after a few minutes, it’s still running, CPU usage is about 16%, see screenshot.

I think i’m able to reproduce this now. It happens when you launch AwesomeTTS from the editor as you mention.

1 Like

@zhushenli I’ve release 1.35 which prevents the high CPU usage bug. However this means that unless you select or copy your field, it won’t be pre-populated in the AwesomeTTS screen. Let me think about how I can restore this functionality.
If you feel happy with my fix, please add a review on AwesomeTTS - Add speech to your flashcards - AnkiWeb


Thanks! :smile: