Anki Forums

AwesomeTTS problem

Hello!
I have used awesomeTTS for a good while now, to add pronunciation to my cards, which worked just fine.
Now as Im adding cards, everyting worked, and just now the addon (or anki?) crashes all the time…
this is what I get:

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you've discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.40 (cf446733) Python 3.8.1 Qt 5.15.1 PyQt 5.15.1
Platform: Linux
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-10-12 09:18:56
Add-ons possibly involved: ⁨AwesomeTTS Google Cloud Text-to-Speech  Microsoft Azure TTS unofficial, Frozen Fields⁩

Caught exception:
Traceback (most recent call last):
  File "aqt/webview.py", line 35, in cmd
  File "aqt/webview.py", line 124, in _onCmd
  File "aqt/webview.py", line 569, in _onBridgeCmd
  File "<decorator-gen-30>", line 2, in onBridgeCmd
  File "anki/hooks.py", line 89, in decorator_wrapper
  File "anki/hooks.py", line 86, in repl
  File "/home/debian/.local/share/Anki2/addons21/516643804/main.py", line 135, in onBridge
    return _old(self, str)
  File "aqt/editor.py", line 443, in onBridgeCmd
  File "/home/debian/.local/share/Anki2/addons21/814349176/awesometts/gui/common.py", line 121, in _show
    self._instance = self._target.constructor(
  File "/home/debian/.local/share/Anki2/addons21/814349176/awesometts/gui/generator.py", line 670, in __init__
    super(EditorGenerator, self).__init__(
  File "/home/debian/.local/share/Anki2/addons21/814349176/awesometts/gui/base.py", line 243, in __init__
    super(ServiceDialog, self).__init__(*args, **kwargs)
  File "/home/debian/.local/share/Anki2/addons21/814349176/awesometts/gui/base.py", line 77, in __init__
    super(Dialog, self).__init__(parent)
RuntimeError: wrapped C/C++ object of type AdvancedBrowser has been deleted

Do u have any tips what I can do?
(OS: Debian 11, Xfce)

This error will be fixed someday, I think. At the moment I can only suggest to either use on-the-fly tts with Google or Azure voices if you don’t review on mobile, use the add-on from the browser window to batch generate audio for many notes at once or install AwesomeTTS - Add speech to your flashcards - AnkiWeb. As far as I know, it’s already fixed there.

1 Like

thank u so much for the quick reply - I got the mentioned Add-On, and that absolutely solved the problem! :slight_smile:

Thanks @kelciour , I believe this is due to the lazy loading of some dialogs and some reference getting garbage collected. This caching of dialogs has been problematic on occasion, I think there’s a better way of doing it (let me think).