Awesome TTS: How to make text substitution work?

I am using Awesome TTS Youdao for Japanese text-to-speech. My cards are written in romanji.

Japanese has the markers “ga” and “wa”, which are pronounced as “gah” and “wah” respectively.

When Youdao reads this, it pronounces them as “G.A. (e.g. Gee-Aye)” and “W.A. (e.g. DoubleU-Aye)”. How can I fix it, so it pronounces them properly?

If you go to Tools > AwesomeTTS > Text > Advanced, there’s an option for text strings substitutions.

I have put the following:
Screen Shot 2021-12-27 at 14.44.11

But it seems to have no effect. It is still read out as “Gee-aye”

Even if I put something different, it still doesn’t work:
Screen Shot 2021-12-19 at 15.50.05
This is still read out as “Gee-aye” instead of “TEST”

In the match, I have put a space before “ga”. This is because I don’t want it to match legitimate words that contain “ga” (e.g. gap) (because I use Awesome TTS for English, Spanish and Japanese). But even if I omit the space it still has no effect.

Any ideas? Thanks!

Hi I’m the maintainer of AwesomeTTS but unfortunately not a Japanese learner. Can you elaborate on why your cards use romaji? Do any TTS engines give acceptable output using romaji?

1 Like

Thanks for your reply and help!

Many of the Japanese courses I do only use Romanji

I used to use Oddcast which worked perfectly. Out of the free options, MacOSX gets the particles correct when Romanji is used (But it’s pronunciation for others words is poor). Google Cloud also gets the particles correct (but it’s too rate limited and it tends to pronunciation non-particles words poorly).

Can other Japanese experts provide some input, is TTS generation possible given Romaji input ? or will it be inaccurate ? I realize your course uses Romaji, but does it also provide the equivalent higarana/katakana/kanji ? My intuition is that these would be much better sources to feed into a TTS engine.

1 Like

I have contacted the publishers but they only have Romanji. It’s not just one course. Lots of popular Japanese learning books+CD packages only use romanji.

Is there any way for me to use the substitutions in AwesomeTTS, so when it sees “ga” it replaces it with something else. As detailed in my opening post, even trying to swap “ga” with “test” still gets the word pronounced as “gee-aye” instead of “test”.

I found with oddcast is was highly accurate.
With Youdao (which I am now using), it’s accurate, it just can’t cope with particles.

Thanks for all your continued help!