Anki Forums

Auto rate typed answer [Official thread]

If you have a problem with the add-on auto rate typed answer post in this thread. This way I get notified. If you make a new thread I will likely miss it.

Everytime I Press “Answer”, it immediately choose “Easy”, “Good”, “Again”. So I can’t see the Back of
my cards. Can you set a delay function for choosing “Easy”, “Good”, “Again”.

Ex: Every x seconds after I Press Answer button, Anki will choose “Easy”, “Good”, “Again”

Thanks. Sounds useful. But there’s so little time and so much to do. I’ll add this to my todo list with a low priority. Who knows when I’ll finish it …

Hi - I have been trying to use the option to auto-code incorrect answers with “again”. However, this seems to mess up the algorithm in Anki that determines when a card has been learned. I’m not sure exactly what is happening, but I know that the cards don’t get advanced as quickly as they would without the add-on (sometimes I get stuck and keep doing the same few cards on an infinite loop, even when I’m getting all of the answers right).

Thanks for taking the time to put together this really useful add-on! I’m using it with my kids to stop them from cheating on their Anki, and it’s so helpful in that regard. :wink:

One more note, in case it is helpful in diagnosing the problem: the toolbar that pops up in the lower left-hand corner seems to rate the card correctly (eg, 4 if you enter the answer within the duration set for easy). However, when I go to the stats, everything is coded as 1. There seems to be a mismatch between the rating that is displayed and what is actually coded.

@Sabrinal1981: I can look into this in about two weeks. But I need more info. Have a look at When problems occur - Frequently Asked Questions . What happens if you disable all other add-ons, restart Anki and use just my add-on: Do you still get the same problem? Which Anki version do you use: To find out: in the main window click on “help->about” in the menu bar (might be slightly different on Macs), then “About”. in the dialog that opens you see the anki version you use. On the bottom of this dialog there’s a button “Copy Debug Info”. Click this and then you’ll have some text with useful info for me in your clipboard. Also post this text.

Hi there,

Thanks for responding! Here are the answers to your questions:

  1. I don’t have any other add-ons, and I’ve tried restarting Anki multiple times, but the problem persists.

  2. I am using Anki version 2.1.49.

  3. Here is the text that shows when I click on “Copy Debug Info”:

Anki 2.1.49 (dc80804a) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-11-24 12:34:37

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
auto rate typed answer ['1836029849', 2021-06-12T10:01, 'None', mod]

===IDs of active AnkiWeb add-ons===
1836029849

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

That’s useful info. I see that you changed the config of the add-on. Could you also post your add-on config. You can view your add-on config like this: in the main window menubar click on tools->add-ons. in the window that opens double click my add-on. Another window should open where you see the config. The config should look like this.

Sure thing. Here’s what I see when I go to the config:

{

"accept_multiple_answers_for_these_notetypes": {},

"easy if shorter than": 12,

"good if shorter than": 15,

"hard if shorter than": 20,

"hard interval for cards with 2 or 3 buttons means again": false,

"ignore case when comparing": false,

"on mismatch ignore user rating, always rate as again/1 (2.1.20+ only)": true,

"on mistake set focus on again": false,

"show tooltip for confirmation": true

}