Audio not playing in desktop client (but does in AnkiDroid)

I’m using audio file links in my cards which play perfectly well in AnkiDroid but not on my desktop.
OS: Windows 10
Anki: 2.1.44

Example audio link in cards:


When I click/play an audio file, I notice that anki runs mpv.exe and mpv.exe continues running (and no sound is produced).
I’m not sure if this is expected behaviour?

If I run mpv.exe manually via commandline, it plays audio perfectly fine.

I’ve tried setting the mpv output log, but it only seems to output the startup log, addining nothing if i try playing more audio clips:

[   0.161][v][cplayer] mpv 0.33.0-268-g416668d3c8 Copyright © 2000-2020 mpv/MPlayer/mplayer2 projects
[   0.161][v][cplayer]  built on Sun Aug  1 13:30:35 +08 2021
[   0.161][v][cplayer] FFmpeg library versions:
[   0.161][v][cplayer]    libavutil       57.3.100
[   0.161][v][cplayer]    libavcodec      59.3.102
[   0.161][v][cplayer]    libavformat     59.4.101
[   0.161][v][cplayer]    libswscale      6.0.100
[   0.161][v][cplayer]    libavfilter     8.1.103
[   0.161][v][cplayer]    libswresample   4.0.100
[   0.161][v][cplayer] FFmpeg version: git-2021-08-01-c50f5460
[   0.161][v][cplayer] 
[   0.161][v][cplayer] Configuration: /home/shinchiro/build64/packages/mpv-prefix/src/mpv/waf configure --enable-static-build --enable-pdf-build --disable-manpage-build --enable-libmpv-shared --enable-lua --enable-javascript --enable-sdl2 --enable-libarchive --enable-libbluray --enable-dvdnav --enable-uchardet --enable-rubberband --enable-lcms2 --enable-openal --enable-spirv-cross --enable-vulkan --enable-vapoursynth --prefix=/home/shinchiro/build64/install/mingw
[   0.161][v][cplayer] List of enabled features: asm build-date cplayer cuda-hwaccel cuda-interop d3d-hwaccel d3d11 d3d9-hwaccel debug-build direct3d dos-paths dvdnav egl-angle egl-angle-win32 egl-helpers ffmpeg ffnvcodec gl gl-dxinterop gl-dxinterop-d3d9 gl-win32 glob glob-win32 gpl iconv javascript jpeg lcms2 libarchive libass libavdevice libbluray libm libmpv-shared libplacebo lua luajit mingw noexecstack openal optimize plain-gl posix-or-mingw rubberband sdl2 sdl2-audio sdl2-gamepad sdl2-video shaderc shaderc-static spirv-cross spirv-cross-static static-build stdatomic uchardet vapoursynth vector vulkan wasapi win32-desktop win32-internal-pthreads zimg zlib
[   0.161][v][cplayer] Set property: log-file="D:\\Users\\Dan\\mpv.log.txt" -> 1

No errors or anything in the console if running anki-console.exe too.

Have just tried updating to 2.1.46 and the problem still persists.

Would definitely be grateful if anyone has any ideas!

Anki doesn’t try to support remote links. Localizing them may resolve the issue. Localize Media - AnkiWeb

Oh I see, thank you. Does Anki sync local media to AnkiWeb, or are the external audio links retained and the local media only used on the device on which Localize Media was used?

Secondary question- if synced, is there a limit to media storage on AnkiWeb? (I was hoping to avoid cluttering your servers with more audio files)

Edit: Answered my own question that there is apparently no current limit on media storage, which is very generous.

Thanks @dae for all your efforts on Anki, it’s much appreciated. Hopefully Sydney gets out of this soon!

1 Like