Audio doesn't play for new cards as of today


I’ve been using the AnkiDroid app to study the Core 2k/6k Optimized Japanese Vocabulary pack for quite a while now. When I opened it today, I discovered that none of the new cards could play any audio, and a message was popping up:

So far I’ve tried syncing, updating the app as I’ve been using an older version and syncing again, checking the same cards on Ankiweb both on my Android and laptop, downloading the Anki app for windows on my laptop, and so forth. The audio can’t be played anywhere, and I’m not sure how to proceed.

The weird thing is that the audio for all of my review cards plays normally, and the audio for new cards was playing normally when I studied yesterday. It’s just today’s new cards that have this problem. I checked the new cards ahead just to see if it was just a small batch of cards that had this problem, but I checked more than 80 cards ahead and they all seemed to have the same problem. I might’ve found one single card among them that could play the first part of the audio, but I’m not sure what that says exactly.

Any help would be greatly appreciated, thank you!

P.S. Apologies if the format of this post is not correct, I’m quite new to this.

1 Like

[Moved this from the Add-ons category, since it isn’t add-on related, and appears to happening for you across all platforms.]

I think the error at the bottom of your screen tells you pretty much what you need to know (and I’m curious where that “Help” link takes you…). Anki seems to be saying it doesn’t have that file, so it can’t play it.

If you run Check Media, Anki will give you a list of files that are referenced on your cards but not in your folder.

Thanks for the quick reply!

First of all, this is where it takes me when I press that help button:

I also tried to run Check Media, and this is what I got:

From what I can gather by that it seems like I am indeed missing a lot of files, however the Check Media hasn’t helped me any further. Is there a way for me to restore those audio files?

As always I appreciate the help!

Is there a way for me to restore those audio files?

You’re assuming that you had the files in the first place – but … did you? Where did you get this deck? Did it come with the files? If you made it yourself, how and where (on what system) did you make it/attach the files?

[Thanks for letting me know about the Help link. Yes, that AnkiDroid Wiki has a lot of great informtion. It’s a great first stop when you have issues. FAQ · ankidroid/Anki-Android Wiki · GitHub]

1 Like

Possibly related: A shared deck is not showing images/playing audio - Frequently Asked Questions

1 Like

Update: I seem to have fixed the problem although I’m not entirely sure how. I’ll note down everything I did in case it helps anyone else.

I’ve been studying a pretty popular shared deck called Core 2k/6k Optimized Japanese Vocabulary which I first downloaded from this website:

In retrospect the problem might’ve been with the source I got the deck from, but back then I didn’t think there would be any problems since it was uploaded on the official Anki web.

This time I downloaded the same deck from another link:

I then imported this deck in both the Ankidroid in my tablet and Anki in my laptop. I synched a bunch of times and then somehow the problem was fixed, at least as far as I can see. The audio in the new cards plays normally and my study progress seems to be the same (at least I hope). I also run Check Media again and this time it showed only 1900 or so files missing, but they were all jpeg files so I don’t really care.

Something else to note, when I tried importing the new deck at first it seemed like it didn’t work. This is the message it displayed on Ankidroid:

I’m pretty sure it said something similar on the computer as well. But I guess it’s all good in the end (fingers crossed).

Thanks for all your help so far!


That message is telling you the import resulted in no new notes or cards – which is completely expected given you were only trying to import the media, right?

The truth is I didn’t really know what I was doing, I just tried to import the entire deck apkg file. I guess that resulted in only the media files getting imported, since there was an identical deck with the same notes/cards already in there? I’m not sure.

Yeah, I think that’s right! That’s why the message didn’t really impact you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.