Anki won't close (v 23.10.1)

Whenever I open ‘browse’, it becomes impossible to close out. Anki isn’t frozen, I just can’t close it…pressing the ‘X’ doesn’t work; ‘alt’ + ‘F4’ doesn’t work; ‘esc’ doesn’t work. The only way I’m able to exit out is if I ‘end task’ through task manager.

I’m running Anki Version ⁨23.10.1 on Windows 11. Please help. This issue is becoming tedious and annoying.

1 Like

Wow. I’m also using Windows 11, and 23.10.1 worked fine for me. I’m on 23.12.1 now.

First things first, try the Troubleshooting - Anki Manual checklist.

1 Like

tried updating to 23.12.1 and it didn’t work. Looked through the troubleshooting guide before I came on here and couldn’t find the answer. Thanks anyway.

1 Like

Did you also try the things suggested? Like – does it happen when you have add-ons disabled? Are all of your add-ons compatible with the version you are using?

1 Like

Any hardware issues? Not enough RAM memory?

Maybe try the Debug Console (use Ctrl+Shift+; to open it). If you type
in the Debug Console and hit Ctrl+Enter, it will tell you how many cards you have in your collection. Is it some really high number?

Try opening the Browse window while the Debug Console is open. Does it print out any error message in the bottom Debug Console window?

Are you able to Sync via the main window? If you have a phone, can you use the Browse functionality there? (on iPhone, the gear wheel from the review screen and then the Browse button)

After doing Check Database, export your collection as a .colpkg from the File/Export menu and then try importing it into a different user profile, and see if Browse will work there.

If that fails, probably you have backups dating from before the problem started happening?

1 Like

In the Debug Console, try typing:
from aqt import dialogs'Browser', mw).setFilter("deck:random_nonexistent_name")
and hit Ctrl+Enter

Does that by any chance successfully open a Browse window with no cards displayed?

1 Like

Thanks for the feedback. it’s one of the dang add-ons.

I’m having the same issue on my Mac.
Which add-ons did you find was the issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.