Anki Forums

Anki was unable to open your collection file.

Before You link me to this article -> https://github.com/jakeprobst/anki-loadbalancer/issues/17

My issue is a bit different

I had anki 2.1.29 installed, in a poor attempt to downgrade it I installed 2.1.22 and tried to
run it. it gave me this error message:

Anki was unable to open your collection file. If problems persist after restarting your computer,
please use the Open Backup button in the profile manager.

I uninstalled 2.1.22 and deleted my ankiweb account, thinking that if I started from a clean slate, the problem
would go away.

I reinstalled 2.1.22 and the problem presisted.

If I clicked on “User 1” the same pop-up would occur.

I added a new profile and anki was able to open. However, a “Profiles” menu opens upon startup and
I need to choose between the profile I created and “User 1”

as of right now I havent done anything with anki but as I plan to use addons, add decks, ect, I imagine that issues will occur down the line due to this happening, I would much prefer to
use anki without the profile options menu.

I don’t see installing the newest version of anki as being of any utility because I want an older version, and if I hold down shift nothing changes.

What should I do about this?

This is covered at the top of https://changes.ankiweb.net/#/

I am currently using my desired down graded version of Anki. All I would like to know is that given my circumstances, should I expect any issues?

Maybe not. But if you do run into issues, the first thing I’ll suggest is updating, as newer versions contain various bugfixes.

Thank you. I’ve fixed the issue however when I was using the most current version of Anki before downloading the older version I hit “downgrade and quit” and then upon downloading the older version the thing downgrade and quit was supposed to fix, which was my problem, still occurred. Maybe something to check out. Again, thank you very much.