Anki returns the old version of the add-on

Hi there, I’m trying to upload a new version of the Quizlet to Anki 2.1 Importer with audio support" add-on (id 1362209126). I can upload an add-on file without any problems but when I run Anki and update the add-on I see the old files instead of the new ones. Previously I haven’t had any issues with this. Does anybody have this issue or maybe I need to do something?

The file has an up-to-date modification time. Are you sure you uploaded the correct file? What is the sha256 of the file you uploaded?

sha256 - 17443de6769cea8671820e32c9df948ebd585b19c6364af045dde5dbc64ca50f
Yes, I’m sure that I’ve uploaded the correct file. I’ve updated my meta.json file (updated a mod prop) and created a new archive. I’ve done it many times before and haven’t had any issues. My meta.json file has this { “name”: “Improved Quizlet to Anki 21 Importer”, “mod”: 1680551218 } . I’ve also added a manifest.json file and when I try to install it locally everything works correctly and I see the last version.

Could you provide me with the file you’re trying to upload so I can try to reproduce the issue?



I switched to your account, clicked Update, selected that file, and proceeded, and it now appears to have the correct checksum - so I’m not sure why it did not work for you.

It’s interesting but today I’ve opened Anki one more time and I’ve seen an update dialog with my add-on. After the update, I see the correct files. Have no idea what was the problem but now it works. Thank you for your help.
p.s. I would not create this topic but users complained about the add-on version

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.