Anki Mac App not opening


My Mac App is not opening. The icon keeps bouncing in the doc and activity monitor shows “Not Responding”.

Opening using console gives following output:

Anki starting...
Initial setup...
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run...
Exception in thread Thread-1:
Traceback (most recent call last):
  File "threading", line 973, in _bootstrap_inner
  File "aqt.mediasrv", line 84, in run
  File "waitress.server", line 78, in create_server
  File "waitress.server", line 244, in __init__
  File "waitress.server", line 361, in bind_server_socket
  File "waitress.wasyncore", line 396, in bind
OSError: [Errno 49] Can't assign requested address

My uneducated guess is that it is a Python server’s Port access issue.

I have tried troubleshooting following steps, but with no result.
a. Deleting and installing previous stable versions as well as beta version.
b. Restarting computer.
c. Opening with No Addons (Shift Key)
d. Resetting disk user permissions using diskutil resetUserPermissions.

Please help resolve this.

I am running latest MacOS version.

Hey, quick question did you got the right anki to your MacBook?
There are 2 anki apps for MacOS

  1. Mac-apple for M1 (2020+) and M2
  2. Mac-intel for machines from 2019 and below


I ensured that I installed only Apple Silicon dmg images.

Do you need the complete dump from the Console?

I updated XCode at about the same time that this issue began - Not sure if it is connected to the issue though.


I figured out the issue.

“can’t assign requested address” is the clue from the dump.

It seems XCode update had mesed up with the lo0 Network interface. The same error popped up in Docker Desktop

I had to run the following command

sudo ifconfig lo0 alias up

Thanks for the prompt reply.