Anki Application Won't Open on Mabook

I have been using Anki for a long time and yesterday I opened the app on my Macbook and it told me to update to the newest version. I downloaded the most recent Intel macbook version on the Anki website, but when I tried to open the application, it just bounced up and down before saying “Application not responding”.

I have tried redownloading many times, restarting my laptop and all other advice on other forums. Nothing seems to be working!

Please advise!!! I really need the app for studying asap

You can try renaming your prefs21.db file to something else then starting Anki, which will reset all your settings, and may help. If it doesn’t, please try both the qt5 and qt6 versions of Anki.

I tried both of those solutions and nothing is working - I’m at a loss. Any other ideas? Thanks

What’s printed when you run Anki from a terminal?

Did you try downgrading to 2.1.54 that you were using before? Older versions are available on the Anki website.

I’m not really sure how terminal words, but spent a long time yesterday researching how to launch anki. Managed to start Anki from terminal, but it just continued bouncing and nothing came up in the terminal box

Have redownloaded loads of different older versions and they are all having the same issue, just bouncing for a while in my dock before saying application not responding

That’s somewhat surprising, I’d expect something to be printed in the terminal provided you didn’t include ‘open’ in the terminal command, and waited a few minutes to rule out an atypically-long startup time. What happens if you try again?

Have you tried both qt5 and qt6 versions of Anki?

Could you please explain why exactly I need to type into terminal, I’m quite unsure and may have did it wrong

Open using the magnifying glass/search icon at the top of the screen, then paste


and press enter.

Yes I’ve been doing that and nothing at all is happening - the application doesn’t even appear in my dock and bounce like it does when I open it manually

Can you attach a screenshot of what you see after pressing enter?

Hmm, very strange. And when you’ve tried the various Anki versions, you’ve been dragging them into your Applications folder and replacing the existing versions when macOS asks if you want to replace, keep both, or cancel?

If you look in your Applications folder, is there only “Anki”, or are there multiple, like “Anki 2”?

Yes I always select ‘replace’. There is only one Anki application too

When i search ‘Anki’ in my files, there are many - could it be due to this?

Those files are fine and likely not related.

You said you tried restarting the computer already. The only other thing I can think of is if you have some form of antivirus running on your Mac, which is fairly rare.

I’m afraid I’m out of ideas :frowning: The only remaining thing you could try is running Anki directly from Python, which is somewhat involved. You would need to install python 3.9.16 from, restart your computer, and then type the following commands in a terminal:

python3.9 -m venv venv
venv/bin/pip install aqt

I’m just downloading python now

Instead of directly invoking the executable within the app package, type

open /Applications/

If you installed it somewhere other than /Applications, type the correct path.

Just tried it and Anki opened via terminal, but the app just kept bouncing up and down for two minutes before saying ‘Application not responding’. Do you have any other ideas please?

There are sometimes crash logs, but finding them is inconvenient and interpreting them is even worse.

Try to remember when it worked last and restore your Anki data from that date.

If you haven’t changed the path to the data, it would be
/Users/(userID)/Library/Application Support/Anki2

I downloaded anki in September 2022 - I’ve tried to download these versions from this time off the Anki website but they didn’t work