Anki Application Won't Open on Mabook

I’m not saying to download Anki again. You’ve already tried that.
It’s possible the data has somehow gotten corrupted. The notes, cards, database.

That is not correct - we want the console output, which open will not show.

@P_S what was shown in the terminal when you ran Anki from Python?

If you leave it for 15 minutes does anything change?

That is possible, but with no console output it implies Anki is not even reaching the stage where it can load data.

How can I restore the data?

I think they are suggesting restoring from a backup, which I do not think will help here. But you can test out the theory by renaming your Anki2 folder and then trying to start Anki. Make sure you rename it back if the test doesn’t work.

I tried that a few days ago and it didn’t work unfortunately. I also downloaded python but couldnt figure it out

Maybe someone close by who’s a computer wizz might be able to assist?

Great news got it working!!! I just gave up and was using the anki mobile app for a few days, then somehow restarted my macbook for something and it automatically opened up! Tried restarting many times before so I don’t know why it worked this time, not complaining though.

The app is slightly lagging and slow on my macbook now which wasn’t the case before, works though which I’m so glad about.

Thanks everyone for all your help :slight_smile:

Glad to hear the issue resolved itself!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.