Anki Fails to launch on arm64 Linux

I have installed Anki on my 2020 M1 MBA running Asahi Fedora Remix.

When I try to run Anki through the terminal, this is my output:

/usr/local/bin/anki: /usr/local/bin/anki: cannot execute binary file

Is there not a port to these machines yet? I know there’s an Apple Silicon version on macOS, but I’m not running macOS as you saw from above. Or maybe this is just some stupid thing on my end. I’m assuming maybe because Anki doesn’t have a 16k pages version, which is what these machines need to run a program (on Linux).

Anki Version: anki-2.1.66-linux-qt6
OS: Fedora Asahi Remix 38
Host: MacBook Air (M1, 2020)
KDE Plasma version: 5.27.8
Qt version: 5.15.10
Window Server: Wayland
Kernel: 6.5.6-403.asahi.fc38.aarch64+16k

Tried the Qt 5 version as well, but failed to launch.

Hi distodev,

I use Anki also on Fedora Asahi on M2 MBA. It works fine, but as dae already linked, you need to use the Python wheels binaries and you cannot use the packaged binaries that you can find on the website or GitHub release page.

After successful installation, this is how I start up Anki:

export QT_QPA_PLATFORM=wayland

nohup anki >/dev/null 2>&1 & disown

Not all of it is strictly needed, so try it out on your own but I needed to set at least the first environment variable to get sharp text inside Anki, otherwise it was close to unreadable. Now it works great!

Of course, it would be even greater if Fedora packaged a recent version of Anki. As I don’t really use Python a lot, the installation process was not great. But the packaged version, while it does work fine on aarch64, is far too old.

When I run the last command on the Python Wheels setup, this is my output:

Traceback (most recent call last):
File “/home/samilkaraduman/pyenv/lib64/python3.9/site-packages/aqt/qt/”, line 13, in
import PyQt6
ModuleNotFoundError: No module named ‘PyQt6’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/home/samilkaraduman/pyenv/bin/anki”, line 5, in
from aqt import run
File “/home/samilkaraduman/pyenv/lib64/python3.9/site-packages/aqt/”, line 46, in
from aqt import gui_hooks
File “/home/samilkaraduman/pyenv/lib64/python3.9/site-packages/aqt/”, line 11, in
from _aqt.hooks import *
File “/home/samilkaraduman/pyenv/lib64/python3.9/site-packages/_aqt/”, line 18, in
from aqt.qt import QDialog, QEvent, QMenu, QModelIndex, QWidget, QMimeData
File “/home/samilkaraduman/pyenv/lib64/python3.9/site-packages/aqt/qt/”, line 15, in
from .qt5 import * # type: ignore
File “/home/samilkaraduman/pyenv/lib64/python3.9/site-packages/aqt/qt/”, line 11, in
from PyQt5.QtCore import * # type: ignore
ModuleNotFoundError: No module named ‘PyQt5’

Did you install Qt?

Yep, I have installed that way in the beginning.

The error message seems to imply otherwise, so I’d double check that step.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.