Fedora 32 Qt info: Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome

I tried installing Anki 2.1.28 on a new installation of Fedora 32 using the following instructions below from Anki Website. Anki will not launch at all!

tar xjf Downloads/anki-2.1.26-linux-amd64.tar.bz2
cd anki-2.1.26-linux-amd64 sudo make install

I get the following error below when trying to run Anki from a terminal.
Qt info: Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
mpv not found, reverting to mplayer
Segmentation fault (core dumped)

I tried using the following commands below, which I found on Anki Website as a possible Fix, and it did not work. I tried logging out, and back in and that did not help.

theme=$(gsettings get org.gnome.desktop.interface gtk-theme)
echo "gtk-theme-name=$theme" >> ~/.gtkrc-2.0
echo "export GTK2_RC_FILES=$HOME/.gtkrc-2.0" >> ~/.profile

I tried removing Anki using the command, “sudo dnf remove anki” from a terminal, but Fedora does not recognize the installation. I was going to attempt uninstalling Anki, and installing an older version from Fedora’s repository, and then upgrade to the latest version to see if that would work. Fedora does not recognize that anki is installed so I can’t remove it.

Am I missing a dependency, or is there some Anki file I need to configure manually?

I can’t reproduce this on a Fedora 32 livecd - maybe it’s an issue with your video drivers.


1 Like

Thank you Damien for you prompt response! How did you install Anki? I used the following commands below from the command line to install Anki.

cd anki-2.1.26-linux-amd64
sudo make install

Your screen shot shows you receiving the same error message i’m receiving. I think you may just be lucky that Anki’s UI is loading for you. Are you sure Anki is functional? I believe installing Anki using the “sudo make install” command may be failing to install a ton of dependencies required by Anki. You can see them in the screenshots below were I used the “sudo dnf install anki” command from the terminal to install the latest version of Anki Available in Fedora’s repository. I believe the latest version available in Fedora’s repository is Anki 2.1.15.

I installed the latest version of Anki available from Fedora’s repository (Anki 2.1.15) from the command line using “sudo dnf install anki”. It listed a ton of dependencies required by Anki that I don’t believe is being installed when running the “sudo make install” command. It took two screen shots to capture them all. You can see them below in the screenshots.

Anki 2.1.15 works, but it contains the bug that will not allow the user to use Copy & Paste with Anki. If I can’t use Copy & Paste then Anki is no good for me. I uninstall Anki 2.1.15 after installing the dependencies needed by Anki, and tried installing Anki 2.1.28 again. Anki will not launch again after installing 2.1.28. I tried installing Anki 2.1.26, and Anki launches, but crashes immediately after launching.

I just tried posting both images showing all the dependencies that I don’t believe is being installed when using the “sudo make install” command and I was informed that I can only post 1 image due to being a new user on the forum. The second image showed python3, Qt5, texlive, and some other stuff. Do you know if these dependencies are being installed when using, “sudo make install” command?

As shown in the screenshot, I ran it from the untarred folder. You should remove any distribution version of Anki, as it is not necessary, and may be causing a conflict. Since I can not reproduce the problem here, the only things I can suggest you try are to change the video driver as mentioned above, or rename your Anki data folder so Anki creates a new one. https://docs.ankiweb.net/#/files?id=file-locations

I removed/uninstalled previous versions of Anki each time before installing a different version.

I don’t know how to change video drivers for my video card with Linux. I’m not sure it is even possible since I think Linux uses Generic driver for most hardware.

I have to run some applications as XWayland due to my older hardware. I see XWayland process running on my System, but no Wayland Process. I have to run Firefox browser as X11 in order for it to work correctly. Is there anything in Anki’s config file that I can change from Wayland to XWayland? I thought I would check before I reformat my computer to remove all the changes I have made to my system trying to get Anki to work.

Never mind. I give up for now trying to get Anki to work on Fedora. I constantly have to worry about Anki and other applications breaking with every update Fedora releases. I have been using Anki’s export option to backup all the decks I have created. Will I be able to import those decks into Anki on a Windows machine?

No experience with XWayland, sorry. And yes, exported decks are not platform-specific

I’m sorry to revisit an old thread, but I think I must in this case. I incorrectly stated above that I was running as x11 Windows/graphics environment on Fedora when in fact I was running as Wayland. Fedora has switched from x11 to Wayland as their primary windows/graphics environment, instead of x11. I was able to verify which environment I was running as with the following command: echo $XDG_SESSION_TYPE

I have tried installing Anki on Linux Mint which I have verified still runs the X11 Windows/Graphics environment, and Anki runs fine on it. Anki just did not install to the system for some reason. It is running from it’s folder like it is a portable app on Mint. I hope I can figure out how to get it to install to the system. I used sudo make install, but before that I ran ./bin/anki so maybe I messed it up doing that. Anyway, I noticed on Anki website it says you must have libwayland-client, but that actually seems to be the problem on my system. Qt does not want to run with Wayland on my system, but it will run on the old X11 protocol. Wayland has broken many applications on my System which is running older BIOS based hardware. I think Wayland is actually the problem, it will break many applications on older systems.

8/12/20 @ 2:46
Correction, Anki did install to the System on Linux Mint which uses X11, it just did not create an icon, or add itself to the List of Applications. There is no icon for Anki, and it is not listed in the Application List, it has to be launched from the Terminal. The Terminal has to be left open for as long as you run Anki, if you close the Terminal then it closes Anki also.