Issues running on Ubuntu 24.04

Don’t run in Ubuntu 24.04 until you change kernel.apparmor_restrict_unprivileged_userns to 0

$ anki
Anki starting...
Initial setup...
Preparing to run...
Wayland support is disabled by default due to bugs:
https://github.com/ankitects/anki/issues/1767
You can force it on with an env var: ANKI_WAYLAND=1
Qt warning: QGuiApplication::setDesktopFileName: the specified desktop file name ends with .desktop. For compatibility reasons, the .desktop suffix will be removed. Please specify a desktop file name without .desktop suffix 
[65597:65597:0211/090730.415203:FATAL:credentials.cc(126)] Check failed: . : Permission denied (13)
Trace/breakpoint trap (core dumped)

But after setting works ok:

$ sudo sysctl -w kernel.apparmor_restrict_unprivileged_userns=0
kernel.apparmor_restrict_unprivileged_userns = 0
$ anki
Anki starting...
Initial setup...
Preparing to run...
Wayland support is disabled by default due to bugs:
https://github.com/ankitects/anki/issues/1767
You can force it on with an env var: ANKI_WAYLAND=1
Qt warning: QGuiApplication::setDesktopFileName: the specified desktop file name ends with .desktop. For compatibility reasons, the .desktop suffix will be removed. Please specify a desktop file name without .desktop suffix 
Qt debug: doh set to ""  --  SystemOnly 
Starting main loop...
mpv not found, reverting to mplayer

I presume that’s with the 23.12.1 Qt6 version of Anki?

Yep

Anki 23.12.1 (1a1d4d54)  
Python 3.9.15 Qt 6.6.1 PyQt 6.6.1
Platform: Linux-6.6.0-14-generic-x86_64-with-glibc2.38

Thanks, I’ve added a note on Install & Upgrade - Anki Manual

1 Like