Anki "not responding" on startup

I have installed the last version 2.1.58 QT6 on Ubuntu 22.04

It is a new, fresh install, but hangs on startup when selecting profiles.

Al so I tried 2.1.58 QT 5, but I then the menu was not sowed (and I repaired database)

The command line shows this:

$ anki
Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run…
Wayland support is disabled by default due to bugs:

You can force it on with an env var: ANKI_WAYLAND=1
Qt info:

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 3.3
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: no

Init Parameters:

  • application-name Anki
  • browser-subprocess-path /usr/local/share/anki/lib/PyQt6/Qt6/libexec/QtWebEngineProcess
  • create-default-gl-context
  • disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
  • disable-setuid-sandbox
  • disable-speech-api
  • enable-features NetworkServiceInProcess,TracingServiceInProcess
  • enable-threaded-compositing
  • in-process-gpu
  • use-gl desktop

Starting main loop…

Any Idea?

I tried with:

And then gnome hang up entirely

Tried with 2.1.58 QT 5 and I get this screen but, I can not star to study

$ anki
Anki starting…
Initial setup…
Preparing to run…
Qt info: Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Qt warning: QSocketNotifier: Can only be used with threads started with QThread
Starting main loop…

Had been looking at this post trying to figure out what was going on since you tried both Qt6 and Qt5

with the recent screenshot, can only redirect for workarounds present in Blank Main Window - Anki Manual

While you are in the manual, try others solutions/workarounds from 2.3.2-2.3.8 (left side)

hopefully it can fix the issue, if not, we gotta wait for one of the devs or someone with experience on linux


Thanks by the clue !

That solved my issue


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.