Problems installing Anki 2.1.66 (QT6)

On Linux over Chrome. I was previously using version 2.1.60 but after Anki suddenly and inexplicably lost the ability to recognise accented characters on an English (US) International keyboard, I decided to accept the offer to install a new version which I always get when starting Anki. This apparently is 2.1.66.

The install appeared to work but when I then type ‘anki’ I get the following, of which I understand not a single word:

Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run…
Wayland support is disabled by default due to bugs:

You can force it on with an env var: ANKI_WAYLAND=1
Qt info: Could not load the Qt platform plugin “xcb” in " " even though it was found.
Qt fatal: This application failed to start because no Qt platform plugin could be initia
lized. Reinstalling the application may fix this problem.

Available platform plugins are: minimalegl, xcb, linuxfb, eglfs, offscreen, vnc, minimal
, wayland, wayland-egl, vkkhrdisplay

Aborted (core dumped)

What is going on and what do I do now?

Many thanks for your response.

I did look at that section of the anki manual, and tried to do what it suggested, but it didn’t work. Specifically I typed “QT_DEBUG_PLUGINS=1 anki” and hit return. As before it complained about something referred to as “the Qt platform plugin “xcb””. I took this to be the name of a missing library, and tried, first, “apt-get xcb” and then “apt-get install xcb”. Neither of these appeared to do anything. Just guessing, I then thought to try “sudo apt-get install xcb”. (As may be obvious I have no idea what any of this stuff means). Anyway the last one appeared to be more successful - at least in that it generated more encouraging output, though still totally cryptic to me - but when I then typed “anki” and hit return, I got exactly the same message as before (as in my original post, again complaining about “xcb”). At this point I gave up and reverted to version 2.1.60.

The anki manual seems to assume that the people who are reading it will all understand sentences like “After installing the library with apt-get or similar, repeat the process” and will know how to do what it says. This is not the case. (I particularly love that “or similar”) I still have no idea if I typed the right thing, or something similar to the right thing but lacking some essential parameter or tassel, or what.

I would be very grateful for any suggestions or explanations.

Please note that I am so ignorant of all this linuxy stuff that I don’t even know how to mark the screen output from a linux session and copy it to eg this anki forum. The usual methods I use didn’t work at all. (In my original post I had to copy it all out by hand)

Thanks for your time and attention.

It is likely one of the xcb libraries, such as the ones mentioned on Install & Upgrade - Anki Manual

Yes, as I say, that is what I assumed. But “sudo apt-get install xcb” made no difference - I still got the same message trying to install anki , and anki failed to start. (I had to reboot the machine) What should I try now? As far as I can see the Anki Manual offers no clue.

Did you try running the command shown in the section I linked you to?

Which command? Are you referring to the one following the instruction “On recent Ubuntu installations, please use the following before installing:”? If so, the answer is No, because as far as I know mine is not a Ubuntu installation at all, recent or not. Am I wrong? How might I know? I thought Ubuntu - which I had only vaguely heard of - was a different thing entirely.

If you have apt on your system, it’s a Debian derivative, and the same instructions should apply.

Do I have apt on my system? What does that mean? As I say, typing “apt-get xcb” did nothing and nor did “apt-get install xcb”. However “sudo apt-get install xcb” appeared to do something (but not enough). Does any of this mean I “have apt on my system”? (The words “Debian derivative” might as well be written in Swahili for all they mean to me; actually the same is true of “have apt on your system”)

But thanks for your help. If I ever feel like upgrading beyond 2.1.60 again, I’ll bear in mind what you suggest.

I had the same problem today with Ubuntu and installed the two missing dependencies as shown in the installation guide and then it worked i.e.: execute the following lines:

sudo apt install libxcb-xinerama0 libxcb-cursor0
cd anki-2.1.XX-linux-qt6
sudo ./

Then Anki should open normally.

To answer your question about distribution and package managers you can read the following. You will probably have a lot of opportunities to use it in the future :slight_smile:

If “sudo apt-get install xcb” did something more than throwing an error message I guess you have Ubuntu. Ubuntu is one of many distributions of Linux. The package manager of Ubuntu is “Apt”, which is basically a program you use via the command line interface and use to install and manage packages/programs.

If you are not sure which distribution you are running it is best to first find that out. For that open a command line tool (hopefully you will find one when searching for a program named “terminal”).
Then type in the following command and execute it:
uname -v

The terminal should now show you the distribution you are running and its version (and some other stuff). The first name in the output will likely be your distribution e.g. Ubuntu and in front of that will be its version e.g. 22.04.1. If there is no “Ubuntu” written here, then you should check what the package manager of your distribution is and how to install the two required packages over it.

Many programs you install can be installed via your package manager and it is advised to use the package manager if possible because it is easier for the user and uninstallation and resolving dependency issues is (mostly) easier. The installation guide shows how to install the two required packages via the package manager of Ubuntu.

The way you installed anki itself is manually i.e. you have some compressed folder of the files, you unpack them with some tool like “unzip” or “tar” and then you install them via an installation script (here If you are ever wondering how to install a tool/program/package after unpacking it. The “README” file will likely have the instructions else maybe an “INSTALL” file.

I hope this helped you a little with handling and understanding Linux :slight_smile:


1 Like

aWeber - many thanks for that detailed and informative post: much appreciated. I am managing with 2.1.60 right now, but as I said to dae, I shall bear in mind all your advice as and when I try again to upgrade.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.