Anki Bug: Problem with a Filtered Deck

I made a custom filtered deck a few days ago and started to use it today. The first few cards went OK, but then an error message came up.

I re-started Anki using shift to disable all add ons. When trying to do a card from my filtered deck another error message came up so I followed the instructions to Check Database. It found that some new cards were in a position >1,000,000 so I followed the instructions to reposition them. I ran Check Databases again. When I tried to do a card from my filtered deck it didn’t work and this error message came up:

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.23 (de9543ff) Python 3.8.0 Qt 5.13.1 PyQt 5.14.1
Platform: Mac 10.14.6
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2020-07-27 14:43:32

Caught exception:
Traceback (most recent call last):
File “aqt/”, line 31, in cmd
File “aqt/”, line 97, in _onCmd
File “aqt/”, line 500, in _onBridgeCmd
File “aqt/”, line 337, in _linkHandler
File “aqt/”, line 270, in _answerCard
File “aqt/”, line 108, in nextCard
File “aqt/”, line 191, in _showQuestion
File “aqt/”, line 213, in autoplay
KeyError: ‘autoplay’

I just double checked and my regular deck and other filtered deck work fine. Any advice on how to approach this issue?

Please empty all your filtered decks, then try again.