Anki 2.1.62 Beta / Release Candidate

Nothing happens when I click on any other notetype in the “change notetype” window on 2.1.62rc1, it simply will not react.


I’ve just reinstall ANKI 2.6.62 (fd509efc) from scratch.
By the way,
the letter c is missing on the page Release 2.1.62rc1 · ankitects/anki · GitHub,
Index of /downloads/beta/ : the RC is not available.

Anyway, in this version, if I want to add a preset / clone a preset / etc… it doesn’t work (as soon as I click on ‘Clone Preset’, the menu is closed)

EDIT : it’s QT5 version (for fullscreen support, ans JLAB addon)
EDIT : I’ve just checked with the beta 1 QT6 : I could rename/clone/… deck options : it worked (then I created some, because I intended to upgrade to RC1 QT6, using software rendering)
I confirm that the Beta 1 is slower to react than the RC1, I’ve just reinstalled (the QT6 version)

I can’t seem to select a Notetype on import.

Here is a screenshot of the file I am trying to import:

Even if I select the Notetype on the Import screen, it goes back to Dictionary Entry Notetype

Tried with addons disabled as well, same thing happens

I confirmed this does not happen in Version ⁨2.1.61 (0c1eaf4c)⁩ - release version.
I see the problem in the 2.1.62 RC1 version in both qt5 and qt6, and it is not only a problem with the dropdowns in the Import screen, I also can’t change any dropdowns in the deck options either. Both are resolved by installing the 2.1.61 release version.

1 Like

Thanks for the reports; these issue were an unintended side-effect of a bugfix. 2.1.62 has now been released as stable, with the only change being a fix for these issues.

If you encounter any further issues, please create a new thread for them.