Anki 2.1.55 Beta 5-6

I installed rustup and ninja in Manjaro

info: syncing channel updates for ‘1.65-x86_64-unknown-linux-gnu’
info: latest update on 2022-11-03, rust version 1.65.0 (897e37553 2022-11-02)
info: downloading component ‘cargo’
info: downloading component ‘clippy’
info: downloading component ‘rust-docs’
info: downloading component ‘rust-std’
info: downloading component ‘rustc’
info: downloading component ‘rustfmt’
info: installing component ‘cargo’
info: installing component ‘clippy’
info: installing component ‘rust-docs’
info: installing component ‘rust-std’
info: installing component ‘rustc’
info: installing component ‘rustfmt’
Updating git repository
Updating index
Updating git repository
Updating git repository
Updating git repository
Updating git repository
Updating git repository
Downloaded block-buffer v0.10.3
Downloaded doc-comment v0.3.3
Downloaded is-terminal v0.4.1
Downloaded pbkdf2 v0.11.0
Downloaded sha2 v0.10.6
Downloaded sha1 v0.10.5
Downloaded clap v4.0.29
Downloaded tokio-macros v1.8.0
Downloaded phf_shared v0.11.1
Downloaded prost v0.11.3
Downloaded zip v0.6.3
Downloaded rustix v0.36.4
Downloaded crypto-common v0.1.6
Downloaded generic-array v0.14.6
Downloaded camino v1.1.1
Downloaded io-lifetimes v1.0.3
Downloaded cpufeatures v0.2.5
Downloaded password-hash v0.4.2
Downloaded snafu-derive v0.7.3
Downloaded digest v0.10.6
Downloaded zstd v0.12.0+zstd.1.5.2
Downloaded junction v0.2.0
Downloaded snafu v0.7.3
Downloaded jobserver v0.1.25
Downloaded aes v0.7.5
Downloaded heck v0.4.0
Downloaded addr2line v0.17.0
Downloaded memchr v2.5.0
Downloaded ahash v0.7.6
Downloaded itertools v0.10.5
Downloaded backtrace v0.3.66
Downloaded aho-corasick v0.7.20
Downloaded base64ct v1.5.3
Downloaded crc32fast v1.3.2
Downloaded hashbrown v0.12.3
Downloaded hmac v0.12.1
Downloaded mio v0.8.5
Downloaded cc v1.0.77
Downloaded zstd-safe v6.0.2+zstd.1.5.2
Downloaded itoa v1.0.4
Downloaded os_str_bytes v6.4.1
Downloaded flate2 v1.0.25
Downloaded anyhow v1.0.66
Downloaded num_threads v0.1.6
Downloaded opaque-debug v0.3.0
Downloaded autocfg v1.1.0
Downloaded crossbeam-utils v0.8.14
Downloaded lock_api v0.4.9
Downloaded proc-macro-error-attr v1.0.4
Downloaded miniz_oxide v0.5.4
Downloaded time-core v0.1.0
Downloaded bytes v1.3.0
Downloaded unicode-bidi v0.3.8
Downloaded time-macros v0.2.6
Downloaded tinyvec v1.6.0
Downloaded unicode-ident v1.0.5
Downloaded version_check v0.9.4
Downloaded bzip2 v0.4.3
Downloaded either v1.8.0
Downloaded url v2.3.1
Downloaded object v0.29.0
Downloaded termcolor v1.1.3
Downloaded getrandom v0.2.8
Downloaded bitflags v1.3.2
Downloaded cipher v0.3.0
Downloaded cfg-if v1.0.0
Downloaded prost-derive v0.11.2
Downloaded constant_time_eq v0.1.5
Downloaded adler v1.0.2
Downloaded parking_lot_core v0.9.5
Downloaded parking_lot v0.12.1
Downloaded form_urlencoded v1.1.0
Downloaded quote v1.0.21
Downloaded rand_chacha v0.3.1
Downloaded regex-automata v0.1.10
Downloaded regex v1.7.0
Downloaded rustc-demangle v0.1.21
Downloaded once_cell v1.16.0
Downloaded pin-project-lite v0.2.9
Downloaded strsim v0.10.0
Downloaded lazy_static v1.4.0
Downloaded serde_derive v1.0.148
Downloaded zstd v0.11.2+zstd.1.5.2
Downloaded tinyvec_macros v0.1.0
Downloaded pkg-config v0.3.26
Downloaded ppv-lite86 v0.2.17
Downloaded log v0.4.17
Downloaded unicode-normalization v0.1.22
Downloaded siphasher v0.3.10
Downloaded typenum v1.15.0
Downloaded clap_lex v0.3.0
Downloaded proc-macro-error v1.0.4
Downloaded scopeguard v1.1.0
Downloaded signal-hook-registry v1.4.0
Downloaded rand_core v0.6.4
Downloaded subtle v2.4.1
Downloaded byteorder v1.4.3
Downloaded time v0.3.17
Downloaded clap_derive v4.0.21
Downloaded serde v1.0.148
Downloaded rand v0.8.5
Downloaded socket2 v0.4.7
Downloaded proc-macro2 v1.0.47
Downloaded syn v1.0.104
Downloaded percent-encoding v2.2.0
Downloaded num-traits v0.2.15
Downloaded indexmap v1.9.2
Downloaded zstd-safe v5.0.2+zstd.1.5.2
Downloaded miniz_oxide v0.6.2
Downloaded smallvec v1.10.0
Downloaded num_cpus v1.14.0
Downloaded bstr v0.2.17
Downloaded idna v0.3.0
Downloaded regex-syntax v0.6.28
Downloaded linux-raw-sys v0.1.3
Downloaded libc v0.2.137
Downloaded gimli v0.26.2
Downloaded zstd-sys v2.0.4+zstd.1.5.2
Downloaded bzip2-sys v0.1.11+1.0.8
Downloaded tokio v1.22.0
Downloaded 120 crates (9.9 MB) in 3.43s
Compiling libc v0.2.137
Compiling cfg-if v1.0.0
Compiling version_check v0.9.4
Compiling proc-macro2 v1.0.47
Compiling unicode-ident v1.0.5
Compiling quote v1.0.21
Compiling syn v1.0.104
Compiling autocfg v1.1.0
Compiling typenum v1.15.0
Compiling memchr v2.5.0
Compiling subtle v2.4.1
Compiling serde_derive v1.0.148
Compiling generic-array v0.14.6
Compiling jobserver v0.1.25
Compiling ahash v0.7.6
Compiling getrandom v0.2.8
Compiling cc v1.0.77
Compiling anyhow v1.0.66
Compiling log v0.4.17
Compiling ppv-lite86 v0.2.17
Compiling block-buffer v0.10.3
Compiling crypto-common v0.1.6
Compiling adler v1.0.2
Compiling serde v1.0.148
Compiling digest v0.10.6
Compiling rand_core v0.6.4
Compiling indexmap v1.9.2
Compiling either v1.8.0
Compiling time-core v0.1.0
Compiling pkg-config v0.3.26
Compiling cpufeatures v0.2.5
Compiling once_cell v1.16.0
Compiling time-macros v0.2.6
Compiling itertools v0.10.5
Compiling lock_api v0.4.9
Compiling proc-macro-error-attr v1.0.4
Compiling io-lifetimes v1.0.3
Compiling parking_lot_core v0.9.5
Compiling crc32fast v1.3.2
Compiling tinyvec_macros v0.1.0
Compiling zstd-safe v5.0.2+zstd.1.5.2
Compiling heck v0.4.0
Compiling bytes v1.3.0
Compiling tinyvec v1.6.0
Compiling rand_chacha v0.3.1
Compiling hashbrown v0.12.3
Compiling aho-corasick v0.7.20
Compiling proc-macro-error v1.0.4
Compiling zstd-safe v6.0.2+zstd.1.5.2
Compiling base64ct v1.5.3
Compiling doc-comment v0.3.3
Compiling smallvec v1.10.0
Compiling scopeguard v1.1.0
Compiling regex-syntax v0.6.28
Compiling rustix v0.36.4
Compiling siphasher v0.3.10
Compiling gimli v0.26.2
Compiling zstd-sys v2.0.4+zstd.1.5.2
Compiling bzip2-sys v0.1.11+1.0.8
Compiling backtrace v0.3.66
Compiling phf_shared v0.11.1
Compiling password-hash v0.4.2
Compiling unicode-normalization v0.1.22
Compiling rand v0.8.5
Compiling regex v1.7.0
Compiling addr2line v0.17.0
Compiling sha2 v0.10.6
Compiling hmac v0.12.1
Compiling miniz_oxide v0.5.4
Compiling miniz_oxide v0.6.2
Compiling cipher v0.3.0
Compiling object v0.29.0
Compiling num-traits v0.2.15
Compiling tokio v1.22.0
Compiling crossbeam-utils v0.8.14
Compiling opaque-debug v0.3.0
Compiling rustc-demangle v0.1.21
Compiling itoa v1.0.4
Compiling linux-raw-sys v0.1.3
Compiling unicode-bidi v0.3.8
Compiling num_threads v0.1.6
Compiling percent-encoding v2.2.0
Compiling bitflags v1.3.2
Compiling form_urlencoded v1.1.0
Compiling idna v0.3.0
Compiling time v0.3.17
Compiling aes v0.7.5
Compiling flate2 v1.0.25
Compiling pbkdf2 v0.11.0
Compiling parking_lot v0.12.1
Compiling bzip2 v0.4.3
Compiling mio v0.8.5
Compiling sha1 v0.10.5
Compiling num_cpus v1.14.0
Compiling signal-hook-registry v1.4.0
Compiling socket2 v0.4.7
Compiling pin-project-lite v0.2.9
Compiling lazy_static v1.4.0
Compiling byteorder v1.4.3
Compiling os_str_bytes v6.4.1
Compiling camino v1.1.1
Compiling regex-automata v0.1.10
Compiling constant_time_eq v0.1.5
Compiling clap_lex v0.3.0
Compiling is-terminal v0.4.1
Compiling termcolor v1.1.3
Compiling runner v0.0.0 (/home/chris/ankidev/build/runner)
Compiling strsim v0.10.0
Compiling junction v0.2.0
Compiling prost-derive v0.11.2
Compiling snafu-derive v0.7.3
Compiling tokio-macros v1.8.0
Compiling clap_derive v4.0.21
Compiling prost v0.11.3
Compiling snafu v0.7.3
Compiling clap v4.0.29
Compiling zstd v0.11.2+zstd.1.5.2
Compiling zstd v0.12.0+zstd.1.5.2
Compiling zip v0.6.3
Compiling bstr v0.2.17
Compiling workspace-hack v0.1.0 (/home/chris/ankidev/tools/workspace-hack)
Compiling url v2.3.1
Finished dev [unoptimized + debuginfo] target(s) in 4m 12s
thread ‘main’ panicked at ‘git failed’, build/runner/src/
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace
~/ankidev main >

Finished dev [unoptimized + debuginfo] target(s) in 0.09s
thread ‘main’ panicked at ‘git failed’, build/runner/src/
stack backtrace:
0: rust_begin_unwind
at /rustc/897e37553bba8b42751c67658967889d11ecd120/library/std/src/
1: core::panicking::panic_fmt
at /rustc/897e37553bba8b42751c67658967889d11ecd120/library/core/src/
2: runner::build::get_buildhash
at ./build/runner/src/
3: runner::build::maybe_update_buildhash
at ./build/runner/src/
4: runner::build::run_build
at ./build/runner/src/
5: runner::main
at ./build/runner/src/
6: core::ops::function::FnOnce::call_once
at /rustc/897e37553bba8b42751c67658967889d11ecd120/library/core/src/ops/
note: Some details are omitted, run with RUST_BACKTRACE=full for a verbose backtrace.

If you manually run the following command from the repo root, what do you get?

git rev-parse --short=8 HEAD


And it returns an exit code of 0 in that case (echo $?)? If you remove line 152 from build/runner/src/, does it resolve the issue?

        .env("PATH", path)

The git command returns 0.
After changing the file and recompiling I get warning messages:

warning: unused variable: path
→ build/runner/src/
149 | fn get_buildhash(path: &str) → String {
| ^^^^ help: if this is intentional, prefix it with an underscore: _path
= note: #[warn(unused_variables)] on by default

warning: runner (bin “runner”) generated 1 warning

and the build fails:

[1/57; 3 active; 0.021s] pyenv
FAILED: /home/chris/ankidev/out/pyenv/bin/python /home/chris/ankidev/out/pyenv/bin/pip /home/chris/ankidev/out/pyenv/bin/pip-compile /home/chris/ankidev/out/pyenv/bin/pip-sync /home/chris/ankidev/out/pyenv/bin/mypy /home/chris/ankidev/out/pyenv/bin/black /home/chris/ankidev/out/pyenv/bin/isort /home/chris/ankidev/out/pyenv/bin/pylint /home/chris/ankidev/out/pyenv/bin/pytest /home/chris/ankidev/out/pyenv/bin/protoc-gen-mypy
/home/chris/ankidev/out/rust/debug/runner pyenv /home/chris/ankidev/out/extracted/python/bin/python3 /home/chris/ankidev/out/pyenv python/requirements.base.txt python/ python/requirements.qt6.txt
Command failed:

/home/chris/ankidev/out/extracted/python/bin/python3: error while loading shared libraries: cannot open shared object file: No such file or directory

[3/57; 1 active; 134.953s] pylib/rsbridge
ninja: build stopped: subcommand failed.

Build failed.

Regarding the RTL at the first launch of the software - the problem is partially solved.
still exists in:
-The deck browser.
-In the “About” window.

-In the editor gear menu.
צילום מסך 2022-12-05 135011

Another bug that I noticed - in QSpinBox the bottom arrow appears to be off until you click on it.
צילום מסך 2022-12-05 150724

Another bug - when clicking on the deck menu, clicking on deck options does nothing and the options window does not open. (I checked this on two profiles)

1 Like

Is anyone else able to reproduce this?

Yes, clicking the deck options does nothing.

On some distros you may need to install libxcrypt-compat.

If you run the following in the debug console, are you then able to open the deck options?


Still no deck options window

If you go back to an earlier beta, does it start appearing again? If so, could you please git bisect to figure out where the problem started?

This issue appeared in the latest beta 7: Version ⁨2.1.55 (fad1ff74)
Beta 6 had no issues⁩

@MIZMU Are you sure you’re running the latest beta? I don’t see the issues in the Qt Widgets of

  • About window
  • Preferences
  • Browser

The edtior gear menu does look like in your screenshot though. I’ll fix that ASAP.

Went back to beta 6 and it appears normal.
Then reinstalled beta 7 and the issue is gone …
Don’t know what happened !
(btw I currently use no add-ons and Qt6)

The problem was only for regular deck options and not for filtered decks

It’s not a bug if 1 is the minimum value for that spinbox. Once the min/max value for such an input is reached, the button to decrease/increase it will indicate it with a color change.


I’m talking about the first run after installation. Before there are profiles.
I’m using the latest beta. And @dea told me to update if anything has changed in this regard.

1 Like

A few more problems:
The card information window does not work. Neither in the reviewer nor in the browser.
In the reviewer, the edit and more buttons are not aligned to the sides in rtl languages
In the reviewer the flag is on the right and not on the left.
Attached is a picture of the above problems:

Highlighting an item in the menu on mouse hover is almost not visible because it is too bright (in Windows)

By that you mean it doesn’t open at all?