Anki 2.1.55 Beta 5-6

If you manually run the following command from the repo root, what do you get?

git rev-parse --short=8 HEAD

9dc6e411

And it returns an exit code of 0 in that case (echo $?)? If you remove line 152 from build/runner/src/build.rs, does it resolve the issue?

        .env("PATH", path)

The git command returns 0.
After changing the file and recompiling I get warning messages:

warning: unused variable: path
→ build/runner/src/build.rs:149:18
|
149 | fn get_buildhash(path: &str) → String {
| ^^^^ help: if this is intentional, prefix it with an underscore: _path
|
= note: #[warn(unused_variables)] on by default

warning: runner (bin “runner”) generated 1 warning

and the build fails:

[1/57; 3 active; 0.021s] pyenv
FAILED: /home/chris/ankidev/out/pyenv/bin/python /home/chris/ankidev/out/pyenv/bin/pip /home/chris/ankidev/out/pyenv/bin/pip-compile /home/chris/ankidev/out/pyenv/bin/pip-sync /home/chris/ankidev/out/pyenv/bin/mypy /home/chris/ankidev/out/pyenv/bin/black /home/chris/ankidev/out/pyenv/bin/isort /home/chris/ankidev/out/pyenv/bin/pylint /home/chris/ankidev/out/pyenv/bin/pytest /home/chris/ankidev/out/pyenv/bin/protoc-gen-mypy
/home/chris/ankidev/out/rust/debug/runner pyenv /home/chris/ankidev/out/extracted/python/bin/python3 /home/chris/ankidev/out/pyenv python/requirements.base.txt python/requirements.dev.txt python/requirements.qt6.txt
Command failed:

/home/chris/ankidev/out/extracted/python/bin/python3: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

[3/57; 1 active; 134.953s] pylib/rsbridge
ninja: build stopped: subcommand failed.

Build failed.

Regarding the RTL at the first launch of the software - the problem is partially solved.
still exists in:
-The deck browser.
-In the “About” window.

-In the editor gear menu.
צילום מסך 2022-12-05 135011

Another bug that I noticed - in QSpinBox the bottom arrow appears to be off until you click on it.
צילום מסך 2022-12-05 150724

Another bug - when clicking on the deck menu, clicking on deck options does nothing and the options window does not open. (I checked this on two profiles)

1 Like

Is anyone else able to reproduce this?

Yes, clicking the deck options does nothing.

On some distros you may need to install libxcrypt-compat.

If you run the following in the debug console, are you then able to open the deck options?

del mw.pm.profile["deckOptionsGeom"]

Still no deck options window

If you go back to an earlier beta, does it start appearing again? If so, could you please git bisect to figure out where the problem started?

This issue appeared in the latest beta 7: Version ⁨2.1.55 (fad1ff74)
Beta 6 had no issues⁩

@MIZMU Are you sure you’re running the latest beta? I don’t see the issues in the Qt Widgets of

  • About window
  • Preferences
  • Browser

The edtior gear menu does look like in your screenshot though. I’ll fix that ASAP.

Went back to beta 6 and it appears normal.
Then reinstalled beta 7 and the issue is gone …
Don’t know what happened !
(btw I currently use no add-ons and Qt6)

The problem was only for regular deck options and not for filtered decks

It’s not a bug if 1 is the minimum value for that spinbox. Once the min/max value for such an input is reached, the button to decrease/increase it will indicate it with a color change.

3 Likes

I’m talking about the first run after installation. Before there are profiles.
I’m using the latest beta. And @dea told me to update if anything has changed in this regard.

1 Like

A few more problems:
The card information window does not work. Neither in the reviewer nor in the browser.
In the reviewer, the edit and more buttons are not aligned to the sides in rtl languages
In the reviewer the flag is on the right and not on the left.
Attached is a picture of the above problems:

Highlighting an item in the menu on mouse hover is almost not visible because it is too bright (in Windows)

By that you mean it doesn’t open at all?

The deck options and card info screens on Windows appear to be caused by 6095b013; I’m investigating.

2 Likes

This topic was automatically closed after 14 days. New replies are no longer allowed.