Anki Forums

Anki 2.1.49 doesn't launch

Hello - first time installing Anki on my desktop. I downloaded the latest version 2.1.49 on Windows 10 21H2 (OS Build: 19044.1466)

The installer completes fine it looks like. I run anki.exe and nothing launches. I do not get an error. I tried disabling my anti virus, running as administrator, and uninstalling/reinstalling with a reboot.

Anything else I could try here? I did check out the help section on the Anki site, and nothing jumped out as a great next step.

Try running from anki-console. See Startup Issues - Anki Manual

Sounds like it may be the same issue as the one mentioned here?

1 Like

I tried the anki-console after you mentioned it, but that was once. It won’t run again. Heres the console output.

[24716] PyInstaller Bootloader 3.x
[24716] LOADER: executable is C:\Program Files\Anki\anki-console.exe
[24716] LOADER: homepath is C:\Program Files\Anki
[24716] LOADER: _MEIPASS2 is NULL
[24716] LOADER: archivename is C:\Program Files\Anki\anki-console.exe
[24716] LOADER: C:\Program Files\Anki\anki-console.exe contains a digital signature
[24716] LOADER: No need to extract files to run; setting extractionpath to homepath
[24716] LOADER: SetDllDirectory(C:\Program Files\Anki)
[24716] LOADER: Already in the child - running user’s code.
[24716] LOADER: Python library: C:\Program Files\Anki\python38.dll
[24716] LOADER: Loaded functions from Python library.
[24716] LOADER: Manipulating environment (sys.path, sys.prefix)
[24716] LOADER: sys.prefix is C:\Program Files\Anki
[24716] LOADER: Pre-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Program Files\Anki
[24716] LOADER: Setting runtime options
[24716] LOADER: Initializing python
[24716] LOADER: Overriding Python’s sys.path
[24716] LOADER: Post-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Program Files\Anki
[24716] LOADER: Setting sys.argv
[24716] LOADER: setting sys._MEIPASS
[24716] LOADER: importing modules from CArchive
[24716] LOADER: extracted struct
[24716] LOADER: callfunction returned…
[24716] LOADER: extracted pyimod01_os_path
[24716] LOADER: callfunction returned…
[24716] LOADER: extracted pyimod02_archive
[24716] LOADER: callfunction returned…
[24716] LOADER: extracted pyimod03_importers
[24716] LOADER: callfunction returned…
[24716] LOADER: Installing PYZ archive with Python modules.
[24716] LOADER: PYZ archive: PYZ-00.pyz
[24716] LOADER: Running pyiboot01_bootstrap.py
[24716] LOADER: Running pyi_rth_win32comgenpy.py
[24716] LOADER: Running pyi_rth_multiprocessing.py
[24716] LOADER: Running pyi_rth_certifi.py
[24716] LOADER: Running pyi_rth_pyqt5.py
[24716] LOADER: Running pyi_rth_pkgres.py
[24716] LOADER: Running pyi_rth_pyqt5webengine.py
[24716] LOADER: Running runanki.py

Tried the beta 6 version they mention in that other thread, and same thing - won’t launch

What do you see when running anki-console.exe with the qt6-beta2 build?

I only have a anki-console.bat on this installation. Here is the output.

C:\Program Files\Anki>anki-console.bat
Anki starting…
Initial setup…
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run…
Press any key to continue . . .

Have you tried running DISABLE_QT5_COMPAT=1 anki-console.bat as suggested?

I haven’t. How do I do that? I tried: anki-console.bat -DISABLE_QT5_COMPAT=1

That env var probably won’t help in this case. It seems something is failing quite early in Anki’s startup, but it’s not clear what. Please try renaming your prefs21.db file to something else and starting Anki again - does that make any difference? If not, would you be willing to try further debug steps including the installation of Python on your system?

https://docs.ankiweb.net/files.html#file-locations

1 Like

Thanks! Renaming prefs21.db and relaunching with anki-console.bat worked. I closed it down and tried to run with anki.exe and that worked too.

I’ll stick with this beta2 build for now.

Thanks all for the help!

(just for the future, in case you need to run something with environment variables: just do as I quoted, DISABLE_QT5_COMPAT=1 anki-console.bat)

1 Like

I am having the same problem, on windows 11, where it wouldn’t launch (The window displays “Not Responding” in the window title bar) and followed the same steps as above. I am now able to launch with the beta after renaming my prefs21 file, but once I clicked “Add” to create a new note, it froze again (The Add window displays “Not Responding” in the window title bar). The weird thing is that it was working a day ago (with some minor bugs but almost fully functional). Can anyone help?