Add-on doesn't work, although no error shows up

Hello! I hope you are having a good day.

So, because I prefer to do my old/green review cards first, I have this add-on known as “Review First” installed. (Review First - AnkiWeb). I had been happily using it on Anki 2.1.44 for probably around a month or so perfectly fine.
However, today, I decided to finally update Anki to .49 and it completely broke. There are no errors given to me, but, the add-on simply doesn’t work. New, fresh/orange, and old/green cards are shown typically (i.e., as if the add-on wasn’t installed). Strangely, the Anki Simulator add-on I have works just fine (the only other add on I have); its just the review first one that is not working.

I have tried a few solutions. Some Reddit posts say that new updates are infamous for breaking addons; so firstly I uninstalled Anki 2.1.49 and re-installed 2.1.44 (the version the add-on worked fine with), but still it does not function at all. I have un and reinstalled the add-on several times as well as reinstall it manually; all to no avail. I tried a much older version of Anki (2.1.9) from when the add-on was originally released, but that gave me an entirely new error message, so I didn’t even try to go down that rabbit hole. I even updated my Windows 10 in a last ditch effort although logically that didn’t change anything.

Sorry to be a bother especially if this is a silly problem. Thank you for any help, in advance.

With every new version, Anki gets better and better by adding new functionality. The downside is that some add-ons based in older code may stop working and need to be updated.
This add-on was made for the first version of the scheduler, and now the program is using the third one, but it looks like the add-on won’t be updated anymore.

Not exactly what you’re looking for, but in newer versions you can choose to see new cards first, review cards first, or new cards mixed with review cards without any add-on, which may work for you.


Ah, I see. That’s unfortunate, and yes it looks like it’s quite an old code. I’m just curious as to why even when I downgrade to a version in which the add-on worked, it still refuses to function correctly. Even more oddly… it’s not even built for the scheduler on 2.1.44 so how did it work in the first place…?

Is there any way at all to get this thing to work again? The “review cards first” thing is better than nothing, and I am grateful to have it but I’d prefer the add-on’s system if it’s at all possible to do so.

Thank you for reaching out!

It sounds like it only works with the v1 scheduler, which will soon be phased out.

1 Like

I see. It’s just confusing to me as to why it worked fine on 2.1.44 initially, but refuses to function when I returned to .44 from .49.

No matter anyway- the “Show new cards after reviews” thing works great.