Error Message Preventing me From Reviewing Cards

Hi all, I keep getting an error preventing me from reviewing my cards. I would really appreciate any help as I am a med student with an exam coming up, and I rely on Anki for all my reviews. I have tried upgrading to the newest Anki and disabling all add-ons by holding shift when I open it. I also tried tools > check database and that didn’t change anything. Do you have any idea what this could be?

Thank you so much. Here’s the error message:

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue to the add-on author.
Debug info:
Anki 2.1.54 (b6a7760c) Python 3.9.7 Qt 6.3.1 PyQt 6.3.1
Platform: Mac 12.5
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2022-09-17 18:53:55

Caught exception:
Traceback (most recent call last):
File “aqt.webview”, line 568, in handler
File “aqt.reviewer”, line 522, in _onAnswerButton
File “aqt.reviewer”, line 447, in _answerCard
File “aqt.reviewer”, line 454, in _after_answering
File “aqt.reviewer”, line 233, in nextCard
File “aqt.reviewer”, line 342, in _showQuestion
File “”, line 189, in autoplay
File “anki.decks”, line 299, in config_dict_for_deck_id
TypeError: argument of type ‘NoneType’ is not iterable

This indicates that add-ons were not actually disabled. I suggest trying to hold shift again. You should see a tooltip telling you that add-ons were disabled if it worked.

1 Like

Your AnkiWeb collection seems fine. Please sync normally, File>Export a backup, then try force a one way sync in the preferences screen, choosing “Download”. Can you reproduce the problem after that?