2.1.36 - filtered decks BUG


Can someone please confirm if this is the case. V2 scheduler enabled.

  1. Create a filtered deck
  2. Cards selected by “Random
  3. Ensure “Reschedule cards based on my answers in this deck” is checked
  4. You will notice that the cards are not actually selected by random, instead they’re selected by Order Added

Here is a SS of the options

1 Like

In fact, no matter which mode you select it will always show them in “Order added”

Thanks for the report, I’ve fixed this in 2.1.37rc1:

1 Like

I downloaded the new release and have the v2 scheduler enabled but my cards/subdecks are still not randomizing in anki web or mobile. Any suggestions?

The above report was about filtered decks - are you reporting an issue with filtered decks, or with the normal review process? Standard decks introduce new cards in subdeck order.

Hello! I am on 2.1.44 and noticing the same issue. My filtered deck is giving me the cards in the oder added, even with the same settings as listed in the screenshot. I have “is:due” too.

I have lots of nested decks. Would this affect randomness in my filtered deck?

I’m sorry to be thinking out loud here! But I am going to put what I’m learning in here in case others search for it. I, like many med students, am using the Pepper deck for Sketchy. It looks like they’re designed where a whole bunch of questions are in one “note” (is this right? One note makes lots of Cards?), and maybe that’s why they’re not randomized for me:

If you look at the deck in the Browse screen and sort by the due column, you should see that the included cards are random. When you fail them, they go into the red learning queue, and they will then come back again in approximately the ordered you failed them.