Toggle between mixed subdecks reviewing and "in decks order reviewing"

Hey there I’ve been using Anki with the old scheduler for a huge time now and I am the type of user that partitions every deck in subdecks subsubdecks.
So to study the 15 or so subdecks in my “mathematics” deck I used to just click on the “mathematics” deck and have all my lessons in the right order (for instance: probability chapter 1, then probability chapter 2,3,4 … then analysis chap 1, 2 … etc).

Now not only are the restriction I set on the children bypassed by the parent’s settings (for instance I keep cards from the past years because I am sending them to some people one year younger than me and I want to be able to edit them easily if they find a slip. This meaning that I had set the ‘review’ and ‘new’ counts on these cards to 0 which prevented them from appearing) but I also now have mixed review between all the sub/subsub decks which makes it really hard to focus. I could open the whole tree and learn these decks one by one but it ain’t very user friendly.

Would it be possible to toggle between something like the old-fashioned way (but everything else that came with the last versions that has been a huge improvement) and the new way which I’m sure suits many people: (Also I know there were some discussion about integrating the “new” count in the “review” count, would it be possible to be able to chose whether the 2 are separated or not? because I prefer to be able to set a “review” and a “new” count separately rather than having the “review” stand as a “total number of cards you’ll see”)

Decks example :

main //set with 9999 new and 9999 reviews
-- Subdeck 1 //set with 9999 new and 9999 reviews
---- SubSubbdeck 1
---- SubSubbdeck 2
---- SubSubbdeck 3
-- Subdeck 2

Old when clicking main:
study SubSubbdeck 1, then SubSubbdeck 2 (with probably the “again” from previous deck) then SubSubbdeck 3 then subdeck 2. Each deck’s new and review was defined by itself as the parent deck is not limiting,

New when clicking main:
Study a mix of all and the number of reviews may be 0 for one deck, these cards will still be reviewed.

If this could be combined with the suggestions here that would be the utmost perfection with regard to the User Experience of reviewing cards in Anki: V3 scheduler new cards and Custom Study behavior: question/requests

Until then If anyone has a good idea on how to roll back to the previous scheduler I’m in :slight_smile:

When I switched back, unchecking the box (well, toggling the radio button) was enough to do it on AnkiMobile, but not on desktop. (On desktop, it would look like it was on v2 on the summary/home/whatever it’s called screen, but when actually reviewing it would exhibit the behavior expected of v3.)

To get back to v2 on desktop, I unchecked the v3 scheduler box, exited with the “quit and downgrade”, then reinstalled the same version of Anki (2.1.48). I’m not sure which parts of that sequence were necessary, but it worked.

Now that I think about it though, since switching back was so seamless on AnkiMobile, it’s probably not intended behavior to be “stuck” on v3 after unchecking the box, so I should probably file a bug report after work today if there isn’t already one.

1 Like

Your description doesn’t match how it should be behaving.

  • The deck you click on controls the total limits, and each individual deck’s limit controls how many cards are taken from that specific deck
  • The order cards are shown in depends on the deck settings. You can order either new cards and/or reviews by deck if you wish.
1 Like

What I meant is that I want to review all the cards from the first subdeck then the cards from the second subdeck etc when clicking on the parent deck.
Also the “new” card value is different depending onwhich deck you click on for instance when I have these decks: (the value in parenthesis is the “new cards” count)

  • D1 (20)
    ----SD1 (3)
    ----SD2 (3)
    ----SD3 (3)

assume I click on all of the subdecks I’ll have learned 9 cards if I had clicked on the D1 I’d have learned 20 cards.

The display order section of the deck options has an option to show in subdeck order.

1 Like

I cannot find this, neither on desktop nor on mobile, even though I went through the whole menus trying to find something like that :confused:

If you click on D1, you would have 9 new cards, since in V3 each deck’s limit controls how many cards from that specific deck can be used.

Deck options:


So I understood it would be better not to turn on V3 on my desktop because Ankidroid apparently does not support it yet, so I don’t see the point. I’ll do it then.

And I don’t know if it is because of the version (⁨2.1.49) or the V2 scheduler but there is definitely a problem with my installation :confused:

Anyway thank you very much :slight_smile:

Edit :
Switched to V3 on Desktop and set it to decks then due date but when reviewing this it mixes new cards from the 4th deck with the reviewing cards of the firsts:
And setting the new/review order to “before” or “after” groups all the reviews before/after all the news which defies the idea to do one deck at a time, I guess I’m just going to stick to opening all the decks one after the other.
I really wish I hadn’t update scheduler to V2 :confused:

@cqg If you click on D1, you would have 9 new cards, since in V3 each deck’s limit controls how many cards from that specific deck can be used.

If so shouldn’t this deck be like 0 new cards? and not 136?
The thing is a subsubdeck has subdecks which include new cards. In the older version it was just considered as a recursive call to the children, which meant that if I want to stop learning new cards from the 20 (grand)grandchildren down here I just had to put “0 new cards” at the top. The thing is, I don’t want to learn cards from the one that has subsubdecks (the one with a 0 1 1) but still wan to learn my regular cards from the other decks

V3 and V2 are compatible. I use v3 in desktop and V2 in Ankidroid all the time. Eventually (and hopefully) Ankidroid wiill be also updated to v3

What’s exactly the problem?

If studyng deck-to-deck is important for you, maybe you should consider simply studying all decks one after another, there’s nothing wrong with that.
On the other hand, maybe you’re not used to the way scheduler 3 manages the deck / subdecks hierarchy, but it has a lot of improvements over older schedulers.

There are subdecks under the first subdeck, those 136 new cards are probably from there. If you don’t want to study new cards from the first subdeck and its children, set “New cards” to 0 for that subdeck and then copy that preset to all subdecks.

Okay, thing is I do most of my studying on ankidroid (all of it actually) so a new scheduler on Desktop does not bring much to me

That was before I upgraded to v3

True but I have a very refined dekc hierarchy (mostly for my studies’ cards) and opening 5 layers of subdecks isn’t very user friendly.

Surely that’s why I suggested a toggle between this version’s (which I’m sure some people like) and the v1’s behavior regarding these cards that if there is a parent deck with 0 new card then it means no card from the subdecks will appear in the decks above.
This can be a useful feature for some, assume you have many different decks underneath, some with 1 new card some with 10, some with special leeches or sorting settings… Then if you don’t have the time to learn new card onde day, instead of putting one parent deck to 0 you’ll have to put all those deck presets’ “new card” value to 0 and then next day to put them all again to their exact value (which then you also need to keep track of))

Also not really related but since I updated to v3 I have a bug with the “easy” value, it’s supposedly 4 days but it varies form 3 to 6 with an average of 5, any clue?


Can you adjust this? (i.e enable disable or increase decrease the impact)

There used to be a defuzz add-on, but I don’t know if it’s still around, or if it’s still compatible with newer versions of the program.

1 Like

It’s not possible to disable fuzzing in the v3 scheduler. Older versions applied fuzz too, but the answer buttons did not reflect it.

1 Like

So I tried to find a workaround and could not find any appart from moving all of my decks outside of the main deck which turns my Anki account into a mess (glad my girlfriend waited before upgrading to V2 and stuck to V1). From what I read online reverting to the v1 scheduler is not recommended… :sleepy:

Do you know if the V3 scheduler is still WIP or if it is the final version? If it is still WIP where do you think is best to suggest this? Github? this site? anywhere else?
Thank you all :slightly_smiling_face:

Sorry, the old behaviour is unlikely to come back. If you want a parent limit to apply, you need to click on the parent or one of its parents.