The hyphen in the subtag is inconsistent

The hyphen in the subtag is inconsistent.

Here is the screenshot.

Anki 24.06.3 (d678e393)  (ao)
Python 3.9.18 Qt 6.6.2 PyQt 6.6.1
Platform: macOS-14.5-arm64-arm-64bit

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
AnkiWebView Inspector ['31746032', 2023-06-28T03:26, 'None', '']
Automatic Basic to Cloze Updated ['800723229', 2022-11-15T21:37, 'None', '']
Edit Field During Review ['1020366288', 2022-08-30T03:38, 'None', mod]
FSRS Helper Postpone  Advance  Load Balance  Easy Days  Disperse Siblings ['759844606', 2024-07-01T10:31, 'None', mod]

===IDs of active AnkiWeb add-ons===
1020366288 31746032 759844606 800723229

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Syntax Highlighting NG ['566351439', 2024-05-20T01:01, 'None', '']

1 Like

Is this a display bug you’d like to report? Or is this causing you functional problems as well?

1 Like

It might not be a display issue but actually the colon characters there are entered with Chinese input? I have a Japanese keyboard installed and entering a colon character for that is indeed different: : vs

You can check whether its a display issue or if the colon character in the tag is actually the Chinese one by searching for tags containing the Chinese colon in the card browser:

My test tag with a mix of romaji : and Japanese :

image

Card browser query finds the card with the Japanese : in the tag

image

1 Like

Here, all the colons are the same English colons, and no Chinese colons are mixed in. For example, in my test in the picture, I added identical English colons as separators, but after pasting them into the label field, they appear differently.

This situation only occurs when there are both Chinese and English in the label. If it is all Chinese, the colons appear larger and are the correct connectors, whereas if it is all English, the connectors appear smaller.

It’s just a display issue, there is no problem with the functionality. Although the connectors of the subtags look different, the correct subtags are still generated in the browsing window. However, if Chinese characters are mixed in, the subtags will definitely not be generated

Ok, it’s display bug then. I notice that in my test with Japanese text in the tag I don’t have this bug:
image

I’m on the Linux version of Anki

  • Version ⁨23.12.1 (1a1d4d54)⁩
  • Python 3.9.15 Qt 6.6.1 PyQt 6.6.1

So, this bug exists only in Mac or only in the newer Anki 24.06.03 or both

@XXHK @jhhr
Thanks for those updates! Can you provide some sample text/tag-name strings [in code-blocks] that appear correctly/incorrectly for you? And – for the benefit of those of us who aren’t smart enough to be able to tell Japanese kanji from Mandarin :sweat_smile: – can you specify whether you’re using Chinese or Japanese characters in each?

Thank you for your work, let me provide some examples and explanations:

The following is all English text and connectors:

A0::AA::BB::CC

The following is text in full English and Chinese colon:

A0::AA::BB::CC

The following is the beginning of the text in English, followed by Chinese text(meaning one two three), and all the connectors are in English:

A0::一::二::三

Most Japanese and Chinese characters use the same Unicode code points so for example A0::一::二::三 is both Japanese and Chinese. The colon character too is exactly the same. So, I think using the @XXHK’s texts should produce the bug the same way as Japanese text. For me, I don’t get the bug using the text A0::一::二::三 as tag:
image

What can be different between Chinese and Japanese is the font though. A Chinese font can display the same character code differently compared to a Japanese font. So another possible cause for the bug might be the specific font the OS uses to display the characters in Anki.

I updated my Anki to 24.06.3 on my Ubuntu 22 and Windows 11 machines.

Linux - no bug:
image

Windows - no bug:
tag_test

So, I figure this on Mac only.

I realized this could be caused by switching the Anki’s UI language so I tried switching my language to Japanese and Chinese but still no bug on Linux or Windows. So, more evidence that this happens only on MacOS

I’m on a Mac, and I pasted this text into a new card. When I go to edit the card, all the :s appear the same. I tried switching Anki’s interface to Chinese, and didn’t notice any difference. Did I miss a step?