2.1.50 TTS bug not addressed in 2.1.51

I just found an issue in 2.1.50 and I don’t see it in the notes for this release candidate. The new feature [anki:tts lang=en_US]Here is {{Field1}} and {{Field2}}[/anki:tts] added by @Rumo doesn’t work well with clozes. When I tried it with a cloze field it read the “c1 colon colon” and “c2 colon colon”

@dae another bug I’ve found. The new tagging in the editor looks great, but in my main collection I can’t even add a tag. I can only type one character and then it freezes. I think this is because I have a lot of tags because I’m able to add new tags in other profiles with less tags

[anki:tts lang=en_US]Here is {{cloze:Text}}[/anki:tts] works for me

If your main collection is the account you’re posting from, I can’t seem to reproduce this. Did you rule out add-ons? Does it happen with the qt6 build?

I had just written {{Text}} instead of {{cloze:Text}}. That’s my fault sorry about that!

Are you able to recreate the lag with tags? I’ve tried that without any add-ons on the pyqt5 build and even after deleting 3/4 of my tags I still get significant lag when trying to add a tag from the editor. Happy to record a screenshare if that’s helpful

That’s what I meant above - when I tested this with your collection on qt6, I didn’t see delays over about a second when attempting to type characters in. I’m not seeing significant lag with qt5 either. Do you get the same behaviour in the qt6 build with add-ons disabled? If so, a quick screenshare that shows the characters you’re typing in might be helpful.

2.1.51qt6 worked pretty well. 2.1.50 and 51qt5 (without any addons) is incredibly slow.

I’m not sure why it’s working so well for you. I installed 2.1.51qt5 just to see if that improved it and still had the slowness.

I’ve got pretty much every addon working for 2.1.50qt5, but it’s going to be months before everything is updated for qt6. Let me know if there’s anything else I can do to test

Another problem that we’ve identified with the new tagging system (I apologize for only just now bringing this up) is that you can’t copy all tags from one card and paste them into a new card or another already existing card. You used to be able to do ctrl+a or manually select everything.

Thanks, added to very slow tag autocomplete rendering in qt 5.14 (mac only) · Issue #1825 · ankitects/anki · GitHub and provide a way to select tags in the tag editor · Issue #1824 · ankitects/anki · GitHub


This is already possible. You can ctrl-click a tag, which will select it. After this, press ctrl-a to select all tags, and then ctrl-c to copy. The copied tags can be pasted into another tag editor.

Hi, when I do this it does work but when I paste into the add tag dialogue for another card it adds the multiple tags as one big tag without any spaces - should i raise a separate issue for this?

I’ve added it to 1824 above.