Text is cut off

Arthur wrote on the old support site:


I just downloaded last version of anki from ankiweb. I installed it again. I started with shift to avoid loading any add-on.
Parts of all windows are missing, as shown in the screenshot.
I am on ubuntu, with everything up to date. Normally, I’ve everything needed to compile anki, even if it should not be relevant here.

  • 2020-06-10-000235_322x235_scrot


Does changing the hardware acceleration option in the preferences help? Does the -alternate download behave differently?

I just tried to turn hardware acceleration off, and it does not solve the problem.

Can you try installing older alphas/betas/stable builds until it start working again?

You can also try changing a few things like: (one at a time): https://changes.ankiweb.net/#/known-issues

  5. echo auto > %APPDATA%\Anki2\gldriver
  6. echo angle > %APPDATA%\Anki2\gldriver
  7. echo software > %APPDATA%\Anki2\gldriver

FYI, angle only works on Windows, and auto/software is what is toggled by the hardware acceleration checkbox. The others are worth trying though.

Current master shows the message "Error loading ‘auto’ graphics driver. Please start Anki again to try next driver. " when I’m trying to run it

I’m trying to checkout older version and do “make run”. But even on 2.1.25 I know have the same message occurring. I don’t get it

I can install the alternate version. However, I can not open the collection; I get the message

Traceback (most recent call last):
File “aqt/main.py”, line 340, in loadCollection
File “aqt/main.py”, line 365, in _loadCollection
File “anki/storage.py”, line 40, in Collection
File “anki/collection.py”, line 68, in init
File “anki/collection.py”, line 144, in load
File “json/init.py”, line 354, in loads
File “json/decoder.py”, line 339, in decode
File “json/decoder.py”, line 357, in raw_decode
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

I have clicked on “downgrad” when I closed from master

I tried downloading from .25 to 2.1.21 from github’s release (it’s not on your https://apps.ankiweb.net/downloads/archive/ page ) and doing sudo make install. Each time I had the same problem of missing buttons

@addons_zz where do you want me to put ANKI_NOHIGHDPI=1 ?

If you read the reference link I gave on my post Changes - Changes you will know. It is a environment variable you export before running Anki. Usually, you open a command line, run export ANKI_NOHIGHDPI=1 and run Anki on the same terminal.

That implies you ran the new version again after downgrading, or something went wrong with the downgrade. The latter should have produced an error in that case however.

Thanks. I only saw indication about how to change this in windows

I opened another collection on 2.1.15, and it worked.

I installed 2.1.25 again in order to downgrade the buggy collection. And then I discovered that it just work again, normally, I have all buttons and everything. Didn’t even need to export an environment variable.
I have no idea what is going on here. I fear that it will eventually break again. But at least, data are saved in this forum for potential future investigation

Using export ANKI_NOHIGHDPI=1 works still. Turning off devices acceleration worked. Hopefully this will be fixed in the future?