Buttons and windows are not correctly being displayed in the latest releases

System information

  • Operating system: Arch Linux
$ uname -sr
Linux 5.7.2-arch1-1
  • Windows manager: dwm
  • Anki version: 2.1.26
$ anki -h | grep '^Anki'
Anki 2.1.26

What I’ve tried (relevant links)

Please, first read the post in the created Unix Stack Exchange forum, then the post created in the Arch Linux forum to have a better comprehension of the issue.

What steps you are taking when the problem happens.

  1. Remove cache files of anki to avoid conflicts (in case previous versions have created files that are being used again)
cd "$HOME/.local/share" && \
	rm -rf Anki Anki2
cd "$HOME/.local/share/tmp" && \
	rm -rf Anki Anki2
  1. Run anki

What problems/errors you are getting when things go wrong.

  • Buttons are not displaying icons.
  • Windows are not correctly being rendered (since some of these windows have huge black gaps).

These problems are only present in the versions that are greater than the “2.1.15” release (this is explained in the post created in the Arch Linux forum)

Can try running Anki from the command line to see if any warning or errors are output to the console?

Can you look into https://changes.ankiweb.net/#/known-issues and try changing a few things like: (one at a time)

  1. ANKI_NOHIGHDPI=1
  2. ANKI_WEBSCALE=1.1
  3. ANKI_WEBSCALE=1
  4. ANKI_WEBSCALE=0.9
  5. echo auto > %APPDATA%\Anki2\gldriver
  6. echo angle > %APPDATA%\Anki2\gldriver
  7. echo software > %APPDATA%\Anki2\gldriver

Related to:

  1. Anki window appearance is broken on certain linux window managers
  2. Blurry font on Windows after v2.1.15
3 Likes

Thanks for the help! The issue has already been solved. I tried every solution you recommended and these were the results.

Each item of the following ordered list shows the command that was executed and whether the issue was solved or not.

  1. $ ANKI_NOHIGHDPI=1 anki (issue was solved)
  2. $ ANKI_WEBSCALE=1.1 anki (issue was not solved)
  3. $ ANKI_WEBSCALE=1 anki (issue was not solved)
  4. $ ANKI_WEBSCALE=0.9 anki (issue was not solved)
  5. $ echo auto > ~/.local/share/Anki2/gldriver (issue was not solved)
  6. $ echo angle > ~/.local/share/Anki2/gldriver (issue was not solved)
  7. $ echo software > ~/.local/share/Anki2/gldriver (issue was not solved)
1 Like

You are not the first user with the same problem. You could bug/irritate QT developers about their bugged tool on: https://bugreports.qt.io/browse/QTBUG-84235

2 Likes