Sync Failure Medical School

I have loaded the AnKing deck and the Anking addons for anki 2.1.22+ (I have 2.1.5). I have synced successfully after using the deck and the addons, but in the past day or so this message has appeared when I try to sync from my desktop Anki:

Syncing failed:
Traceback (most recent call last):
File “aqt\”, line 382, in _sync
File “aqt\”, line 362, in _abortingSync
File “anki\”, line 116, in sync
File “anki\”, line 196, in sanityCheck
File “anki\”, line 53, in reset
File “anki\”, line 753, in _resetRev
File “anki\”, line 750, in _resetRevCount
File “anki\”, line 195, in _walkingCount
File “anki\”, line 517, in parents
KeyError: ‘AnKing::Zanki Step Decks::Zanki Hematology & Oncology’

I have no idea how to resolve this so that I can use the Anki Mobile App. Any help would be much appreciated!!!

If your message is correct, you are using a version of Anki 2.1.5 that was released in 2018 with a bunch of add-ons that have been tested to work on 2.1.22, which was released in 2020. I would recommend sorting out the version discrepancies first.

Thanks Andrew. I updated Anki, and now I’m getting a different error message:
Debug info:
Anki 2.1.30 (06a69c25) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1
Platform: Windows 10
Flags: frz=True ao=True sv=1
Add-ons, last update check: 2020-08-11 15:17:57

Caught exception:
Traceback (most recent call last):
File “aqt\”, line 37, in cmd
File “aqt\”, line 123, in _onCmd
File “aqt\”, line 547, in _onBridgeCmd
File “aqt\”, line 171, in linkHandler
File “aqt\”, line 189, in browseLinkHandler
File “aqt\”, line 1043, in onBrowse
File "aqt_init
.py", line 105, in open
File “C:\Users\chris\AppData\Roaming\Anki2\addons21\874215009\advancedbrowser\”, line 207, in init
origInit(self, mw)
File “<C:\Program Files\Anki\decorator.pyc:decorator-gen-140>”, line 2, in init
File “anki\”, line 638, in decorator_wrapper
File “anki\”, line 629, in repl
File “aqt\”, line 599, in init
File “aqt\”, line 666, in setupMenus
File “aqt\”, line 535, in call
File “anki\”, line 583, in runHook
File "C:\Users\chris\AppData\Roaming\Anki2\addons21\1918380616_init
.py", line 79, in setupMenu
a.setShortcut(QKeySequence(getUserOption(“Shortcut of ‘Number of tags’”, “Ctrl+t”)))
File “C:\Users\chris\AppData\Roaming\Anki2\addons21\1918380616\”, line 25, in getUserOption
if key in userOption:
TypeError: argument of type ‘NoneType’ is not iterable

Can you make any sense of this?

I should not that this used to occur when I tried to sync, but not I am able to sync but not able to change certain settings or “Browse”

The issue was solved by completely removing all add-ons and reinstalling the updated versions.

1 Like