Stuck when editing a card

When learning cards or from explore and going to edit mode, a small window with a loading bar that displays “Processing” pops up. Then it’s not possible to close any anki window. It happens very often but not always. To close anki I end the process and open again.
The only addons I have are Add table and Image occlusion enhanced.

Anki 23.12.1 (1a1d4d54) (ao)
Python 3.9.15 Qt 6.6.1 PyQt 6.6.1
On linux

1 Like

Have you tried Troubleshooting - Anki Manual ?

1 Like

SAME HAPPENING WITH ME everytime , in these latest versions

this forced me to use the old version 2.1.66

after 2.1.66 all versions having this issues

i have tried all recent version Q5 Q6 versions

but nothing works
i am irritated , they are not fixing this issue…

PLEASE ANKI , FIX THIS FIRST , donot focus on just giving new versions

FIXING BUG is very important

You get the same answer, even though you’re yell-y. You should go through the troubleshooting list I posted – paying special attention to #2 and #6 (which is apparently what worked for OP) – because they are the most likely causes.


sir i have done troubleshooting
all the steps

still PROCESSING bug is occuring while editing cards during reviews ,
i am facing this issue for so long !
please GIVE US FIX
really need , i have everything on MY ANKI , my MLE exam is coming

That’s more useful information than the yelling and scolding, certainly. I’m sure you understand that if this isn’t happening for everyone, and basic troubleshooting fixes it for most folks, and it isn’t reproducible – then it’s impossible to fix, right? So facts are going to be much more useful here than hyperbole.

What happened with each of the display drivers that you tried?
Did you run Anki with add-ons disabled for each one?

1 Like

I have disabled all the Adds on
I have tried each video driver

Sorry I didn’t scold or yell …
It was just ouf of frustration.

I don’t know what I will do with all my thousands of cards… I just not feeling good about this…

Tried everything possible…

Okay, now that we know you’re through those steps – is what you are seeing exactly the same as what OP reported?

Is it reproducible, and if so – how do you reproduce it? What Anki version, what OS version, all add-ons are disabled, and then …?

This is happening when I suppose underline a word or ,bold a word
Basically editing in BROWSE CARDS and during reviews if I change some word or highlight a word

It shows processing (never ending window)
So I shut anki down with Task manager.

I just deleted my 100K+ cards to fix this. I thought I am having too many cards
Still I tried, it is showing like this.

Basically it happened after 2.1.66 version

2.1.66 working is fine for me… but I am afraid … upto when this old version (2.1.66) will be functional… what if someday it (V 2.1.66) stop working , and unfortunately I can’t use latest version…
What would I do then…

Version ⁨23.12.1 (1a1d4d54)⁩
Python 3.9.15 Qt 5.15.2 PyQt 5.15.5

i have tried all versions after 2.1.66
i am getting same issue

kindly help thank you so much

Are you sure that you have disabled add-ons?

After you make changes to enable or disable an add-on, you have to restart Anki for the changes to take effect.

Yes brother ,
Restarted Anki
Even I restarted my laptop many times

Uninstalled, installed anki many times

You’ve listed underline, bold, “change,” and highlight.

  • What do you mean by “change”?
  • Does it happen every single time you make one of these edits to a card, or just sometimes?
  • In your screenshot, it looks like you selected LE-FORTS fractures, which was already bold, and you’re trying to add underline to it – is that right? Does this also happen when you select plain text that doesn’t already have some other formatting?
  • What about italics? (I don’t mean that to be flippant, but it’s very similar to those other formatting features, and conspicuously not on your list.)
  • Are you applying the formatting using the mouse (clicking the toolbar) or using a keyboard shortcut?
  • Is this Windows? 10 or 11?
1 Like

i meant by changes ,

if i erase some words, paste a photo , if i do bold, italics, highlight some word (basically any edit in the card) , then most of the time it shows processing & processing window disappears instantly but sometimes
processing window get stuck for hours as i have shown in Screenshot.

it is happening sometimes but happening constantly during reviews,
or suppose if i am not doing cards, i am doing these changes directly form card BROWSER , same issue happens , i earlier thought it is only during reviews (& simultaneously editing cards) , but that not the case.

out of 10 times 4 times its happening.

i am applying formatting from both keyboard & clicking the toolbar.

windows 11 . 8GB RAM , RYZEN AMD 5 3550H Processor

i am numb, what to do , ANKI is MED SCHOOL TO ME , i dont have other device otherwise i would use another one to resolve this issue.

Thankyou so much for replying me, for helping me out!
BIG THANKS for listening,
May God Bless you!

just now see i was doing cards, , when i pasted a screenshot there , it stuck on processing , now i have to END THE PROCESS by task manager.


8 GB is a fairly small amount of memory for a modern machine.

Are you running other programs that use a lot of memory? Google Chrome for instance. That could cause slowdowns due to a lot of memory swapping.

You might be able to add RAM memory to your computer. This is often the quickest way to smooth out performance issues with an older computer.

Does the Processing… behavior still occur right after you reboot your computer, and when Anki is the only program running?

1 Like

So, to summarize:

  • Making any change to a Note
  • In the Browse Edit window or the Study > Edit window
  • Most of the time, it shows the “Processing” window
  • About 40% of the time the “Processing” window gets stuck
  • Windows 11, any version after 2.1.66

And this is happening even with no add-ons? You’re holding Shift when running the program, until you see the confirmation?

When was the last time you ran a Check Database and Check Media (Tools menu)?


i have disabled all the addons , (i also tried that holding shift key method and also disabled in adds on tab)

the screenshot i posted above is after disabling adds on only.

i have tap check the database yesterday .

now i am doing your last suggested step i.e check media

thankyou for responding & summarizing my problem.

here you can see the RAM USAGE , enough space to run ANKI

i just pasted a screenshot in note , i pasted for 3 time ,nothing issue happend (to check the issue) but when i pasted 4th time , it got stuck

and this is after check media & check database , no addson

MY 2.1.66 version is best for me…
I am enjoying this

I have my INDIAN licensing exam in 2024 December

Can you guys please tell me ,
Will I able to use my Anki version 2.1.66 till my exam or not ??

I have created thousands of cards ,I don’t want to mess up with my preparation, I will not use anki latest versions… I will stick to my version of august 2023 (2.1.66)

Just assure me upto when I can use this old version of anki ?
Please … I hope this bug will be fixed soon in the coming updates .

Thankyou for supporting and listening

2.1.66 is the most recent version before 23.10, and it’s recent enough that you definitely should be able to use it until December at least.

One drawback is that you can’t use the FSRS scheduler in that version, and it is considerably more efficient than the v3 scheduler.