[solved] Anki cant handle too long path in hyperlinks. old: Anki can activate some hyperlinks, but not some

i use hyperlinks from anki, and usually a click can directly open to a topic inside mindmanager,

HTML code for the card:




this is for a basic note type,
the 1st link works, the 2nd didn’t.

any help?
this is the 1st time the link doesn’t work,
i’ve been using anki for 1 year, thx

they both are using UNC path, they both are mindmanager maps.

the problem i would guess is

  1. the path’s length, OR
  2. the path contain some characters that is invalid.

thank you.

the 2nd link itself should be valid,

as I can click it inside mindmanger to bring up the target node in mindmanager,

it is just inside anki that that link doesn’t work (but the 1st one work)


I don’t think anyone can provide a good answer without seeing your HTML clearly. Try using the “preformatted text” option (here in the forum) and make sure the HTML is shown correctly in your post.

1 Like
<br><a href="mj-map:///\\ws001\cell00y\0-i\j-r\november\network-home-setting\1305-home-network[221129T144018].mmap#oid={EFCB322A-F467-43D8-8AF4-FE7B9B3687BE}">working</a><br><br><a href="mj-map:///\\ws001\cell00m\kb-m24h\lks_00_main\m_related\my_understanding_med_mm_b120102\folder_4_review\c\cidp-chronic-inflammatory-demyelinating-polyradiculoneuropathy-s-folder\CIDP.mmap#oid={D90F4FDE-86DF-4BBF-905C-ED689E9346F4}">non-function</a><br><br><a href="mj-map:///\\WS001\cell00y\0-i\a-i\charlie\computing-management\computing-management-20220302T142557.mmap#oid={831E8D4D-1FBA-4E81-B0FE-903075A52561}">another-cell00y</a><br><br><a href="mj-map:///\\ws001\cell00m\kb-m24h\lks_00_main\my_doc_mb-open\voice-recording-mm\voice-recording-index.mmap#oid={C52486CB-8159-4A1C-9016-E7F2A316420E}">anothercell00m</a>

hi, i tried 4 more.

i have my disk/usb shared as “cell00?”

the hyperlinks to all cell00y worked

the no.2 hyperlink to cell00m not working,

yet the no.4 hyperlink to another place in cell00m worked.

so analyzing no.2 and no.4 may help?



i moved the file CIDP.mmap to \cell00m\ , the link becomes
mj-map:///\ws001\cell00m\0-test-candel\CIDP.mmap#oid={D90F4FDE-86DF-4BBF-905C-ED689E9346F4} and it worked.

obviously is due to the too long path length.

may be see if could increase the limit later?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.