"show answer" function unable to work

Hi! I am encountering a weird bug with Anki. When I click “show answer” on closed caption cards, the corrected answer shows up, but an error message with the following info immediately shows up:

Anki 2.1.49 (dc80804a) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.15.7
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2022-03-10 17:46:07

Caught exception:
Traceback (most recent call last):
File “aqt/webview.py”, line 541, in handler
File “aqt/reviewer.py”, line 496, in _onAnswerButton
File “aqt/reviewer.py”, line 422, in _answerCard
File “anki/scheduler/v2.py”, line 459, in answerCard
File “anki/scheduler/v2.py”, line 487, in _answerCard
File “anki/scheduler/v2.py”, line 836, in _answerRevCard
File “anki/scheduler/v2.py”, line 873, in _rescheduleRev
File “anki/scheduler/v2.py”, line 962, in _updateRevIvl
File “anki/scheduler/v2.py”, line 910, in _nextRevIvl
TypeError: ‘>’ not supported between instances of ‘NoneType’ and ‘int’

The button at the bottom continues to read “show answer” rather than switching the “again, hard, good, easy” as it normally does. I tried disabling all of the add ons, restarting anki, and restarting my computer twice but none of it worked. I also tried Tools → Check Database and then restarted anki and my computer but that did not fix the problem. Any advice is appreciated! Thanks!

I can’t seem to reproduce the problem with your AnkiWeb collection. If you are still experiencing it after updating to the latest beta, could you let me know a specific card that is triggering it?


Hi! It randomly seemed to resolve itself later that day. I’m not sure what changed. Thanks for your effort!