Shared Deck Is Not Showing Images/Playing Audio


I’m experiencing issues with the Anki app on my macOS and iOS devices. Occasionally, audio files play, but often they don’t. When they do play, it’s only a part of the file and the sound is distorted and unclear. I also notice that images often don’t load, but that’s a minor issue. I’ve ensured that syncing is always complete before I test, and all audio and image files are fully loaded. I’ve also used the ‘Check media’ and ‘Check database’ features in the Anki app’s ‘Tools’ section. Importantly, I only use Shared Decks from the official Anki website, not from third-party sites.

I am using Anki for macOS (MacBook Pro, 2023, M2).

Anki version:
Version ⁨23.12 (55ef11af)⁩
Python 3.9.15 Qt 6.6.1 PyQt 6.6.0

macOS version:
14.2.1 (23C71)

But, the audio files are not working as expected.

I have consulted these links before posting (unfortunately, I cannot paste any links in here, it prevents me from doing so. Please query this in your search engine to reach the links instead):

  1. FAQ: A shared deck is not showing images/playing audio
  2. Anki Forums: anki-on-mac-sound-stops-working/681

What I’ve tried:

  1. Reinstalling Anki.
  2. Trying all versions of Anki:
    Anki for macOS 11+ (Intel, 23.12 Qt6),
    Anki for macOS 12+ (Apple Silicon, 23.12 Qt6),
    Anki for macOS 10.13.4+ (Intel, 23.12 Qt5)
    via: apps[.]ankiweb[.]net

macOS 11+ (Intel, 23.12 Qt6) = Doesn’t open after loading.
macOS 10.13.4+ (Intel, 23.12 Qt5) = Loads very slowly, but opens.
macOS 12+ (Apple Silicon, 23.12 Qt6) = Works fast, as expected.
But all three do not work for audio and image files.

  1. Tried downloading the latest stable version of anki-23.12-mac-apple-qt6.dmg from GitHub: ankitects/anki/releases/tag/23.12. But it seems to be the same version as that of the Anki download page.

  2. Tried this suggestion (see screenshot):

    But it results in:

  3. I also tried it on the iOS version of Anki, the iOS app works flawlessly (for audio only)!

Could someone please kindly assist me with this issue?
Thank you in advance! And thank you for your time.


A quick update on the issue at hand:

I tried Parallels® Desktop for Mac.
And then tried to install Anki on it. Now it works.
But the only drawback is that I need to run Windows through Parallels on my MacBook to make Anki play audio files.

It’s a little bit of a bummer, but a workaround for now.
Kind of defeats the purpose of downloading Anki for macOS.

Would still appreciate any help I can get. It might help others out too.


Another update:

I just tried to use Anki for macOS 12+ (Apple Silicon, 23.12 Qt6) again, and now it works.
I didn’t even restart the app. Maybe Parallels enabled a driver when it was booting?
I tried closing Parallels and then restarting Anki for macOS 12+ (Apple Silicon, 23.12 Qt6), and it still works.

So for now, the issue is resolved! Although I don’t know how exactly.
Images still don’t load, but I don’t really care about that for now anyway.

So I’ll regard this as resolved for now.

That’s an odd one, but glad to hear your issue has resolved itself.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.