Request: .deb package for Chromebook users

Hello Damien,

Could you consider maintaining a .deb package to allow Chromebook users to install Anki desktop in a Crostini container with a single mouse click.

There are quite a few Chromebook users on the forum, and I think that they would be delighted to have a simple solution.

I have a Asus Flip c302, and I saw that Linux tools were in the stable chanel. It installed Debian GNU/Linux 11 (bullseye). I have installed Obsidian.deb with only a mouse click. Not bad for Linux.

Thanks for reading.

Hello back. Is this Damien? If it is you, greetings from Osaka. You are not the sole developer of Anki anymore? I used to post quite often with the nick nodatalog a long time ago. We had a talk about PWA a while back, and you said that it was not likely to happen.

Back to the point I installed Anki via FlatPack (I haven’t used Linux for a long time, and these packaging methods are new to me) Without too much surprise, I have a bunch of errors with the QT permissions. But anyway, it works.

What does it take to have a .deb, or a snap, an appimage, or a Flatpack next to the .exe and the .dmg builds, and in addition to the .tar to simplify the Anki installation on Linux (that’s not Chromebook specifically).

@dae Your reply was a quote :slightly_smiling_face: I missed the expand button.

You cannot just install the Linux version?

  1. Download
  2. Unzip
  3. Open a terminal window.
  4. Change directory into the newly unzipped data (cd).
  5. Install after reading the README.md, which tells you how to run the installation.

I am sorry, if the above is not possible on a Chromebook; I have not used one in years.

Hi!

Even back then, it wasn’t only my work. If you look at the change notes of recent releases, you’ll see contributions from quite a few other people.

https://changes.ankiweb.net/changes/2.1.50-59.html

@matta

Excellent suggestion! I removed the Anki flatpack package. It did not go well with the Set Font Size addon. I installed the tar.bz2. Anki is now running great on this Chromebook :partying_face:. The only missing part is the lack of an Anki icon in the launcher.

The wording was bad. I remembered that you had contributors. I wondered for a moment if this had become a team project, until I clicked on the expand button.

Any reasons why there not an official .deb or flatpack package for linux next to the .dmg and .exe? I had a good experience this time, but it has not always been the case. If I recall I had to:

  1. install the Anki outdated package from my distro first (it was ~400 MB of dependencies) in order to avoid any dependencies issues.
  2. remove it
  3. then install Anki for Linux on your webpage.

There is probably a better way of doing it. But, if you provided one of these new packages for Linux that include all the necessary libraries, I’d welcome it.

I do not know how to edit the items in your Chromebook launcher. But there should be a way.

On Linux Mint, which I am running, we right-click on the menu icon on the task bar, choose Configure and then go from there. When I get to the icon used for the application link/shortcut, I double-click on it and am able to follow the path to the appropriate icon within the Anki installation.

Presumably, there is a similar path for ChromeOS.

There is an existing binary bundle available, and I’m stretched for time as it is. Even if someone were to come along and contribute a script to build a .deb file from the existing binary bundle, there’s no guarantee they’d stick around to deal with any problems that come up in the future, and then it becomes yet another thing I need to maintain.

Thanks to both of you for the replies. I have removed & reinstall the VM & Container to make a fresh install of Anki 2.1.50 QT 6. Anki opens :smile: after installing the missing library libsmime3.so, but it returns some error messages. Do you think it is fine? Do you have any advice, or perhaps I should open a separate thread?

name@penguin:/usr/local/share/anki$ ./anki 
Anki starting...
Initial setup...
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run...
Qt warning: Ignoring unexpected wl_surface.enter received for output with id: 7 screen name: "Screen5" screen model: "226D" This is most likely a bug in the compositor. 
Qt warning: Ignoring unexpected wl_surface.enter received for output with id: 7 screen name: "Screen5" screen model: "226D" This is most likely a bug in the compositor. 
Qt info: 

GLImplementation: desktop
Surface Type: OpenGL
Surface Profile: NoProfile
Surface Version: 3.1
Using Default SG Backend: yes
Using Software Dynamic GL: no
Using Angle: no

Init Parameters:
  *  application-name Anki 
  *  browser-subprocess-path /usr/local/share/anki/lib/PyQt6/Qt6/libexec/QtWebEngineProcess 
  *  disable-features DnsOverHttpsUpgrade,ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture 
  *  disable-setuid-sandbox  
  *  disable-speech-api  
  *  enable-features NetworkServiceInProcess,TracingServiceInProcess 
  *  enable-threaded-compositing  
  *  gpu-preferences UAAAAAAAAAAoAAAQAAAAAAAAAAAAAAAAAABgAAAAAAAwAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAgAAAAAAAAACAAAAAAAAAAAAAAAAAAAAAIAAAAAAAAAAgAAAAAAAAACAAAAAAAAAA= 
  *  in-process-gpu  
  *  use-gl desktop 
 
Starting main loop...
mpv not found, reverting to mplayer
Qt warning: Wayland does not support QWindow::requestActivate() 
Qt warning: Ignoring unexpected wl_surface.enter received for output with id: 7 screen name: "Screen5" screen model: "226D" This is most likely a bug in the compositor. 
Qt warning: Ignoring unexpected wl_surface.enter received for output with id: 7 screen name: "Screen5" screen model: "226D" This is most likely a bug in the compositor. 

Those are warnings, and can probably be ignored.

Thank you Damien :+1: