QtWebEngineProcess.exe - System Error

Hello I’m taking a fairly intensive Chemistry class over the summer and my professor shared Anki with the class, it sounds perfect for me but I’m having some issues launching it. When I double-click on the Anki icon, an error message pops up that says “The code execution cannot proceed because QT6 (QT5 when I’ve tried to download the other version) WebEngineCore.dll was not found. Reinstalling the program may fix this problem”
I’ve tried redownloading the same version of Anki and the other version multiple times, I downloaded a dedicated uninstaller software so I’d be sure I was completely reinstalling everything.

After a decent amount of google searches I believe a small amount of people have encountered this issue but that it is relatively uncommon. I’ve also tried downloading the webengine core separately and then putting it in my Anki folder but have had no luck.

Thank you for any help that you guys can give me on this topic, forgive me if it’s an easy solution, I’m not the most tech savvy person

1 Like

Are you installing Anki in the default location, or somewhere else like a network drive?

Do you have an antivirus running on your machine?

2 Likes
  • What OS are you using?
  • Which version/flavor are you trying to install – https://apps.ankiweb.net/ ?
  • Do I understand you correctly – this is after you successfully install, when you’re trying to run the app?

The most common solution for things like this is to delete the Anki program folder and do a clean install – of course, that shouldn’t be necessary for a brand new install.

I am not finding a “WebEngineCore.dll” anywhere on my system, or in Anki’s text string database. I’m wondering if you have another app on your system that uses (or in the past that used) a Qt engine, and that is interfering somehow? Have you searched your system for QtWebEngineProcess or WebEngineCore?

1 Like

Thank you for your response!
I’m using Windows 11, I’ve tried downloading both QT5 and QT6 on a fresh slate after deleting Anki. You are understanding me correctly, this is happening after a successful install: sometimes I’ll get the popup and nothing will show up and other times Anki will launch but the application will be completely blank except for the “file, edit, tools, view” bar on the top.

After typing in “QTWebEngineProcess” I see Anki but also Calibre, could Calibre be interfering with it? Nothing shows up when I look for “WebEngineCore”. I’m performing the search in the OS folder

That does make me thing that another Qt process is in the mix – perhaps a newer or older version that isn’t compatible with Anki.

When you get Anki running, look in the task manager and search for Qt – you should see (at least) 3 processes for Anki (though, since your display is blank, you might only see 1) –
image
Right-click > Properties for each of them and make sure they are running from your Anki program folder.

Do you regularly use Calibre? Do you know what version it is? Perhaps its Help > About also says what Qt version it’s using?

1 Like

This is all I see when I end up with the blank screen on Anki. I see Anki on the “apps” section but no webengine process. Again this is after trying both versions of Anki and redownloading it multiple times. Shutting down the computer and trying again.
As far as Calibre I just updated it so I’m running version 7.13.0

Other things to try –

  • Are you changing the installation path from the default? If so, would you try installing it without doing that? – This is what as worked for others with a similar error. Reddit - Dive into anything [But don’t follow any of the other “download a random dll from the internet” bad advice there.]

  • Installing and running Anki as portable – Managing Files - Anki Manual


Another ref – but it seems like you already tried this?

Yes every time I’ve tried installing it again I haven’t touched anything in regards to the file path. I guess at this point my last report is running it from a flash drive but I also can’t seem to get that running. It’s probably a simple mistake on my end if you could take a look at how I’m typing it in. I’ve tried putting the text file in and outside of the “Anki” folder and either way no matter what I do when I right click the text file it just gives me the option to edit it instead of launching Anki.

I suspect that is Windows “protecting” you from running the bat. You can see it’s calling it a “Text Document” instead of a “Windows Batch File”.

Example of one of mine:
image

This looks like some dependable, low-risk advice on ways to deal with that – but your Googling might get you something better.

just gonna copy a couple of tips from another thread:

  1. Restart your PC, go to %localappdata%\Programs and delete the Anki folder.
  2. Reinstall anki, do not change default installation directory.
  3. Press Win+R on your keyboard, type “cmd.exe” and press enter. Then type “%LOCALAPPDATA%\Programs\Anki\anki.exe” in the command prompt (assuming you used the default installation directory).
  4. Dump the console output in a new reply here.
1 Like