Problem with updating card template

My systems:

iMac 27” 8GB RAM, 512 GB SSD macOS Big Sur Version 11.5.2

11’ iPad Pro iPadOS 14.7.1

The following was done on my iMac

When I click on one of my decks I get the following message.

Back template has a problem:
Found ‘{{#Notes}}’, but there is no field called ‘Notes’
More information

This is on Card Template

I click on More information, and it takes me to the web support page entitled Card Template has a problem. On that page is says:

You can correct mistakes on the template by opening the card templates screen:

§ On the computer version, edit a problem card, and then click on the Cards… button

It also says:

Found ‘{{Field}}’, but there is no field called 'Field’

This indicates your template includes the name of a field that doesn’t exist. To fix the problem, locate the
{{Field}} inside the card template, and remove it.

OK, I click the Edit button.

I click on the cards button.

It shows the Front Template. OK no mention of {{#Notes}} there.

I click on Back Template. Ah, there it is:

I highlight




…. And press delete. It’s gone! Yesss!!!

I then click on the Save Button.

Now I get another message saying:

Card template 4 in notetype SPANISH 15 has a problem.
See the preview for more information.

OK, I will fix that later. Let’s see if I’ve fixed the first problem. So, I click the red button at the top of the window to close it. A small window opens up and asks: Discard Changes? With No and Yes buttons. I click no because I want to keep the changes. Still the window does not close.

Hmmm. Click the Cancel button. A small window opens up and asks: Discard Changes? With No and Yes buttons. I click no because I want to keep the changes. Still the window does not close.


I cannot get out of this window UNLESS I click Yes on the window that says Discard Changes. If I do that, of course, the changes are not saved. The




… still remains.

What am I doing wrong?

Just click on “Save” instead, if you want to save and not discard the changes.

I did. I clicked on Save and then tried to close the window. Couldn’t close the window. It would keep asking if I wanted to discard the changes or not. If I said I did not, the window would not close.

When you clicked “Save”, did a window like the below pop up?


Not quite. Very similar. This is what I see when I click Save. Note that the Card Template is 5 but the message indicates an error in Card Template 3.

Could you send a print screen of “Card template 3” please?

OK, here it is. Unfortunately, I have already corrected it to remove the reference to the {{#Notes}} field. I am going through all 29 templates and removing the references to these fields. I have the same error in Card Templates 3,4,5,7,13,16,17,18, and 19. When correct these errors it says there is an error in Card Template 20, which I do not know how to correct. I am including screen shots from Card Template 3 and Card Template 20.

Addendum: All templates from 20 to 29 inclusive have the same message: “The front of this card is blank.”

Go to “Tools” and select “Empty cards”, you should be able to see a list of all the cars that have their front blank. By clicking on one of them, you’ll be redirected to the browser, where you can edit the card if you will.

OK, it shows 8 empty cards out of a deck with 2927. I would be very happy to just delete the 8. How do I do that?

Just select “Delete.”


But keep in mind that only the “Front” seems to be blank. Maybe the “Back” has some important information that you want to keep.

OK, I’ve checked the cards and do not need any information there. I have done the following:

Removed the 8 cards from the deck.

Removed the 10 templates which showed “The front of this card is Blank” from the deck. Each of those templates had 0 cards associated with them.

Removed 9 instances of the Notes field from the templates.

Saved the templates.

It appears that everything is now working correctly.

Thank you so very much for your help on this!!!

1 Like

You’re welcome, glad I could help you!

1 Like