Anki Forums

Problem with syncing after the latest update to 2.1.43

Hello,

I updated to version 2.1.43 with no issues.
After I launched Anki for the first time after the update I got the message offering me to update to the schedule.
After I update it successfully, whenever I try to sync my collection I’m asked to pick between uploading to AnkiWeb or downloading from it.
I pick to upload but then a few seconds later it fails and shows me an error message that reads “either the upload was corrupt, or your collection has exceeded the 250MB limit”.
At this point, since I can’t sync my collection to AnkiWeb, it means I can’t do my reviews, so I have no choice but to pick “download from AnkiWeb” instead to avoid the syncing issues, but then the message asking me to update the scheduler also returns, and if I try to update it again, the same story I described above repeats…
I tried to use “check database” and it showed me a message that some cards got “fixed” or something, but the syncing problem remains.
So right now the only way I can continue doing my daily Anki is if I purposely don’t update to the new schedule, but I kinda want it, I want my Anki to be up to date and running smoothly.

Now, my collection IS big (I exported my collection as a coldpkg file and its size is 1.5 GB), but I’ve had no issues with syncing it before and I don’t see why its size should matter to this scheduler update. Is that the issue? How do I fix it other than removing cards and decks (I really don’t wanna do this)? Could it indeed be a “corrupt” upload instead? Why does it mean and how do I fix it?

I’ll appreciate your help on this,
Thanks!

1 Like

Your collection was already twice the limit, but you’ve been flying under the radar by not doing any full syncs until now. ~450 notes in your collection are multiple megabytes in size each, perhaps because you disabled paste filtering when adding them. If you remove them or clean them up, it should shrink your collection under the limit.

The following in the debug console will tag them with ‘huge’. It will take a while.

mw.col.db.execute("update notes set tags = tags || ' huge' where length(flds)>500000")
nids = mw.col.db.list("select id from notes where length(flds) > 500000")
mw.col.after_note_updates(nids, True)

https://docs.ankiweb.net/#/misc?id=debug-console

1 Like

Thanks for the help, but when I try using the debug console as you said nothing happens and I get this traceback error:

Traceback (most recent call last):
File “aqt\main.py”, line 1466, in onDebugRet
File “”, line 3, in
AttributeError: ‘DBProxy’ object has no attribute ‘after_note_updates’

What should I do?

It seems that the debugging or something has tagged my problematic huge notes as ‘huge’.
In the Anki browser I sorted all my cards according to this tag and indeed it shows 455 cards.
I now also know what’s in common to all those cards: I use Anki to study languages and I’m using a chrome extension that merges the css styles into the html.
Now whenever I learn a new word based of a Wiktionary entry, I copy the html with css of the declension table of that entry to a field in the notes (so that I’ll have the declension table right in front me when I learn and review the vocabulary).
Apparently, this takes quite a lot of space in my collection. It probably adds too many irrelevant style fields instead of just the ones actually needed for the table, creating over-bloated html.
Question is, how do I now remove those from my notes (other than doing so manually and slowly)?

Sorry, I’ve tweaked my earlier post to fix the error. I think there’s a HTML cleaning add-on out there, maybe that would help.

1 Like