Problem with new cards

HI!!
I have a huge problem.
I have just organized my decks in subdecks for each subjects such as histology, anatomy etc.
However I realized when revising that Anki makes me study new cards that I have added only recently whereas some cards that I have added two days before have still not appeared as my new cards . Is there a way that my new cards appear in the order that I set them to? I’m not a native english speaker sorry if my problem is not comprehensible

Tools–Pref: switch to Random order, and then - back to Ordered mode.

1 Like

just to add a few notes:

when you set new card to show randomly and not in order added, shows newly added new cards before older new cards (sounds a bit complicated, if you don’t understand it just tell me to give you an examle :D). in this case if you want to go full random, you’ll have to do what @vit said.

if you want your new cards to show in order that you have created them, just leave it on “show new cards in order added”.

Thanks to you both!! I just found the option. So if I want my new cards to show them in the same order that I added them I click « show new cards in order added »? Is that right ? But will anki select a bit of each subdecks or only from the subdecks that I added most recently ?

Like my problem is that I have 8 subdecks and each day I want to review a bit of each class. However, when I was revising it only showed me cards that I added for one subdeck which was let’s say anatomy.
Which annoys me because I still haven’t reviewed my new histology and statistics flash cards that I added before the new anatomy flashcards. And I want to do each day like 20 new cards from EACH subdecks.
I don’t know if you understood my problem please tell me if not!!

when you use parent deck/subdecks, and you try to review your cards from the parent deck. anki goes through subdecks in alphabetical order.
for example in the picture below:
image
if I try to review all my cards from test deck, anki will show all cards in test1 then when it has no cards, it’ll show me cards from `test2’.

one way to change that is to set new card limit for subdecks to 5. this way, it’ll only show me 5 new cards from test1 then it’ll show me 5 new cards from test2 etc.
without letting test1 consume all parent new card limit.

in your case, you can create an options group and set new card limit for than to 20 and set it as option group for all your subdecks.
if you’re not sure how to do that, ask here and I’ll guide you :smiley:

2 Likes

oh my GOD that’s absolutely my problem !! I would love your help! I’m not quite sure on how to do that ! Is it possible that I set a limit different for each subdeck? Let’s say I want overall a limit of 10 new cards per sundeck but there’s one deck where I want to learn more new cards

yea, that’s possible.
I’ll make a video in a few minutes and send you the link here.

1 Like

You are so nice ! thank you a lot for taking the time for me !

just make sure other settings for the options group are same as their previous options group.

if you just use the default and have never changed anything in your options group, just doing what I did in the video should be enough.

1 Like

in this case, just create a separate options group for that particular deck.
showed you how to create option groups in the video

Capture d’écran 2020-12-23 à 13.04.47
I think it works now! I’m going to review later my anki deck so I will keep updated !

Hi! I have the same problem with the new cards and wanted to watch the video to also fix it, but when clicking on the file it says its unavailable, could you possibly walk me through how to fix this?

https://uupload.ir/view/i6mr_options_group.mp4/

there you go

2 Likes

Thanks!